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About this guide
This guide describes how to use MXDM to monitor and manage SQL/MX databases.
Related Topics
“Publishing history” (page 7)
“New and changed information” (page 7)
“Supported Release Version Updates (RVUs)” (page 7)
“Audience” (page 7)
“Related documentation” (page 8)
“HP encourages your comments” (page 11)

Publishing history
This guide supports HP NonStop SQL/MX Release 3.2 until otherwise indicated by its replacement
publication. The publication date and part number indicate the current edition of the document.

Publication DateProduct VersionPart Number

August 2012HP NonStop SQL/MX Release 3.2691119-001

New and changed information
HP NonStop MXDM User Guide for SQL/MX Release 3.2 is a new document.

Supported Release Version Updates (RVUs)
This publication supports J06.14 and all subsequent J-series RVUs and H06.25 and all subsequent
H-series RVUs, until otherwise indicated by its replacement publications. Additionally, all
considerations for H-series throughout this manual will hold true for J-series also, unless mentioned
otherwise.

Audience
This guide is intended for those who perform standard database administration tasks. It provides
basic concepts and task information to get you started quickly and easily.

Organization
Table 1 (page 7) describes the chapters in the manual.

Table 1 Chapters in the manual

DescriptionChapter

Introduces MXDM, and discusses the features and the functional flow“Introduction to MXDM” (page 12)

Discusses the prerequisites of MXDM and the procedures to install and uninstall
MXDM

“Installing and uninstalling MXDM”
(page 15)

Discusses the procedures to start up MXDM, create system definitions, connect to,
and disconnect from a system

“Managing MXDM system objects”
(page 18)

Discusses the MXDM UI and its elements“Navigating MXDM” (page 26)

Discusses basic operations that you can perform in MXDM“Performing basic MXDM
operations” (page 38)

Discusses the procedures to view database objects on a system“Viewing database objects” (page
47)
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Table 1 Chapters in the manual (continued)

DescriptionChapter

Discusses the procedures to view and manage MXCS objects“Managing MXCS objects” (page
76)

Discusses the procedures to launch and configure RMXCI settings using MXDM“Launching the NonStop SQL/MX
Remote Conversational Interface”
(page 96)

Discusses the SQL Whiteboard and the procedures that you can perform using the
SQL Whiteboard

“Using the SQL Whiteboard”
(page 98)

Related documentation
This manual is part of the HP NonStop SQL/MX library of manuals.

NonStop SQL/MX customer library
The following are the manuals in the SQL/MX customer library:

• Introductory guides

Describes differences between NonStop SQL/MP and NonStop SQL/MX
databases.

SQL/MX Comparison Guide for
SQL/MP Users

Describes basic techniques for using SQL in the SQL/MX conversational interface
(MXCI). Includes information about installing the sample database.

SQL/MX Quick Start Guide

• Installation guides

Describes how to plan for, install, create, and upgrade a SQL/MX database.SQL/MX Installation and
Upgrade Guide

Describes how to manage a SQL/MX database.SQL/MX Management Manual

Describes how to install NSM/web and troubleshoot NSM/web installations.NSM/web Installation Guide

• Reference manuals

Describes the syntax of SQL/MX statements, MXCI commands, functions, and
other SQL/MX language elements.

SQL/MX Reference Manual

Describes SQL/MX messages.SQL/MX Messages Manual

Defines SQL/MX terminology.SQL/MX Glossary

• Connectivity manuals

Describes how to install and manage SQL/MX Connectivity Service (MXCS),
which enables ODBC and other connectivity APIs to use NonStop SQL/MX.

SQL/MX Connectivity Service
Manual

Describes the SQL/MX Administrative Command Library (MACL) available with
the SQL/MX conversational interface (MXCI).

SQL/MX Connectivity Service
Administrative Command
Reference

Describes how to install and configure HP NonStop ODBC/MX for Microsoft
Windows, which enables applications developed with ODBC API to use NonStop
SQL/MX.

ODBC/MX Driver for Windows
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Describes how to use SQL/MX Remote Conversational Interface to run the RMXCI
commands, and SQL statements interactively or from script files.

SQL/MX Remote
Conversational Interface
(RMXCI) Guide

Describes how to use the NonStop SQL/MX Database Manager (MXDM) to
monitor and manage the SQL/MX database.

HP NonStop MXDM User Guide

Describes the NonStop JDBC Type 2 Driver functionality, which allows Java
programmers to remotely develop applications deployed on client workstations
to access NonStop SQL/MX databases.

HP NonStop JDBC Type 2
Driver Programmer's Reference

Describes the NonStop JDBC Type 4 Driver functionality, which allows Java
programmers to remotely develop applications deployed on client workstations
to access NonStop SQL/MX databases.

HP NonStop JDBC Type 4
Driver 3.0 Programmer's
Reference

• Migration guides

Describes how to migrate databases and applications to NonStop SQL/MX,
and how to manage different versions of NonStop SQL/MX.

SQL/MX Database and
Application Migration Guide

Describes how to migrate NonStop SQL/MX, NonStop SQL/MP, Enscribe
databases and applications to HP Integrity NonStop NS-series systems.

NonStop NS-Series Database
Migration Guide

• Data management guides

Describes the SQL/MX data structures and operations for data mining.SQL/MX Data Mining Guide

Describes how to produce formatted reports using data from an SQL/MX
database.

SQL/MX Report Writer Guide

Describes the features and functions of the DataLoader/MX product, a tool to
load SQL/MX databases.

DataLoader/MX Reference
Manual

• Application development guides

Describes how to embed SQL/MX statements in ANSI C and COBOL programs.SQL/MX Programming Manual
for C and COBOL

Describes how to understand query execution plans and write optimal queries
for an SQL/MX database.

SQL/MX Query Guide

Describes how NonStop SQL/MX integrates transactional queuing and
publish/subscribe services into its database infrastructure.

SQL/MX Queuing and
Publish/Subscribe Services

Describes how to use stored procedures that are written in Java within NonStop
SQL/MX.

SQL/MX Guide to Stored
Procedures in Java

• Online help

Contents and reference entries from the SQL/MX Database Manager User
Guide.

SQL/MX Database Manager
Help

Overview and reference entries from the SQL/MX Reference Manual.Reference Help

Individual messages grouped by source from the SQL/MX Messages Manual.Messages Help

Terms and definitions from the SQL/MX Glossary.Glossary Help

Context-sensitive help topics that describe how to use the NSM/web management
tool.

NSM/web Help

Context-sensitive help topics that describe how to use the Visual Query Planner
graphical user interface.

Visual Query Planner Help
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The NSM/web, SQL/MX Database Manager, and Visual Query Planner help systems are accessible
from their respective applications. You can download the Reference, Messages, and Glossary
online help from the HP Software Depot, at http://www.software.hp.com. For more information
about downloading online help, see the SQL/MX Release 3.2 Installation and Upgrade Guide.

Notation Conventions

Hypertext Links
Blue underline is used to indicate a hypertext link within text. By clicking a passage
of text with a blue underline, you are taken to the location described. For example:
This requirement is described under Backup DAM Volumes and Physical Disk Drives.

General Syntax Notation
This list summarizes the notation conventions for syntax presentation in this manual.
UPPERCASE LETTERS. Uppercase letters indicate keywords and reserved words.
Type these items exactly as shown. Items not enclosed in brackets are required. For
example:
MAXATTACH

lowercase italic letters. Lowercase italic letters indicate variable items that you
supply. Items not enclosed in brackets are required. For example:
file-name

computer type. Computer type letters within text indicate C and Open System
Services (OSS) keywords and reserved words. Type these items exactly as shown.
Items not enclosed in brackets are required. For example:
myfile.c

italic computer type.Italic computer type letters within text indicate C and
Open System Services (OSS) variable items that you supply. Items not enclosed in
brackets are required. For example:
pathname

[ ] Brackets. Brackets enclose optional syntax items. For example:
TERM [\system-name.]$terminal-name

INT[ERRUPTS]

A group of items enclosed in brackets is a list from which you can choose one item
or none. The items in the list can be arranged either vertically, with aligned brackets
on each side of the list, or horizontally, enclosed in a pair of brackets and separated
by vertical lines. For example:
FC [ num ]

[ -num ]

[ text ]

K [ X | D ] address

{ } Braces. A group of items enclosed in braces is a list from which you are required
to choose one item. The items in the list can be arranged either vertically, with
aligned braces on each side of the list, or horizontally, enclosed in a pair of braces
and separated by vertical lines. For example:
LISTOPENS PROCESS { $appl-mgr-name }

{ $process-name }

ALLOWSU { ON | OFF }

10

http://www.software.hp.com


| Vertical Line. A vertical line separates alternatives in a horizontal list that is
enclosed in brackets or braces. For example:
INSPECT { OFF | ON | SAVEABEND }

… Ellipsis. An ellipsis immediately following a pair of brackets or braces indicates
that you can repeat the enclosed sequence of syntax items any number of times.
For example:
M address [ , new-value ]…

[ - ] {0|1|2|3|4|5|6|7|8|9}…

An ellipsis immediately following a single syntax item indicates that you can repeat
that syntax item any number of times. For example:
"s-char…"

Punctuation. Parentheses, commas, semicolons, and other symbols not previously
described must be typed as shown. For example:
error := NEXTFILENAME ( file-name ) ;

LISTOPENS SU $process-name.#su-name

Quotation marks around a symbol such as a bracket or brace indicate the symbol
is a required character that you must type as shown. For example:
"[" repetition-constant-list "]"

Item Spacing. Spaces shown between items are required unless one of the items is
a punctuation symbol such as a parenthesis or a comma. For example:
CALL STEPMOM ( process-id ) ;

If there is no space between two items, spaces are not permitted. In this example,
no spaces are permitted between the period and any other items:
$process-name.#su-name

Line Spacing. If the syntax of a command is too long to fit on a single line, each
continuation line is indented three spaces and is separated from the preceding line
by a blank line. This spacing distinguishes items in a continuation line from items
in a vertical list of selections. For example:
ALTER [ / OUT file-spec / ] LINE

[ , attribute-spec ]…

HP encourages your comments
HP encourages your comments concerning this document or this product. We are committed to
providing products and documentation that meet your needs. Send any errors found or suggestions
for improvement to docsfeedback@hp.com.
Include the document title and part number of the document.

HP encourages your comments 11
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1 Introduction to MXDM
This chapter discusses the following topics:

• “Overview” (page 12)

• “MXDM features and functionalities” (page 12)

• “MXDM functional flow” (page 13)

Overview
MXDM is an integrated graphical user interface (GUI) client that enables you to connect to and
manage multiple NonStop SQL/MX databases. Using MXDM, you can browse database and
SQL/MX Connectivity Services (MXCS) objects, execute DDL and DML statements, view query
results, manage MXCS objects, assign access permissions to system users, and launch the HP
NonStop SQL/MX Remote Conversational Interface (RMXCI). RMXCI enables you to perform
administrative and database management tasks by running SQL statements interactively or from
script files.
For more information on RMXCI, see HP NonStop SQL/MX Remote Conversational Interface
(RMXCI) Guide.
Related Topics
“MXDM features and functionalities” (page 12)

MXDM features and functionalities
MXDM provides the following features and functionalities:

• Database and MXCS objects—enables you to perform the following:

Browse database objects. For each schema, you can view its tables, indexes, views,
procedures, and SQL/MP aliases. You can also view details of individual SQL/MX
objects.

◦

◦ Browse MXCS objects. On a managed system, you can view the MXCS services, data
sources, MXCS servers, and MXCS user permissions.

◦ View a summary of groups of objects, such as, schemas in a catalog, tables in a schema,
indexes on a table, and so on.

◦ View information related to the size of the schema.

◦ Use the SHOW DDL tool to generate and save the Data Definition Language (DDL) script
for a group of SQL/MX objects.

◦ View information related to table profiles and statistics.

◦ View EMS logs.

• SQL Whiteboard —enables you to execute queries and view data results. Using the SQL
Whiteboard, you can perform the following:

◦ Execute DDL and Data Manipulation Language (DML) statements.

◦ Persist queries across sessions for reuse.

◦ Copy query results to a spreadsheet.

◦ Highlight a portion of an SQL statement and execute (syntax highlighting).

◦ Cancel an executing query.
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◦ Open and save query text to a file.

◦ Use parameters in queries.

• MXDM Framework —enables you to perform the following:

Manage multiple SQL/MX databases using a single instance of MXDM.◦
◦ Save the connection definition when you connect to a system the first time, and retrieve

the definition automatically during subsequent attempts to connect to that system.

◦ Access tools using menu and toolbar options.

◦ Customize the elements displayed in the UI.

◦ Copy grid contents to a spreadsheet.

◦ Launch RMXCI.

• Data source and connectivity management — If you have the operator permission, MXDM
enables you to perform the following:

◦ Add information related to environmental variables, such as, Control Query Defaults
(CQDs), DEFINEs and SETs, and Control Table Statements.

◦ Start and stop data sources.

◦ Stop server processes.

◦ Start and stop MXCS services.

◦ View user permissions.

NOTE: Only the SUPER.SUPER user can assign and change user permissions.

Related Topic
“Obtaining version and build information” (page 38)

MXDM functional flow
The functional model within which MXDM operates includes the following components on the client
workstation:

• MXDM

• Windows ODBC/MX driver
On the NonStop system, you must install the required MXCS objects and create those database
objects that you want to manage using MXDM. Figure 1 (page 14) shows the MXDM functional
flow.

MXDM functional flow 13



Figure 1 MXDM functional flow

The following is the sequence of events involved in establishing the connection between MXDM
and the server components, and in managing the objects:
1. MXDM sends a connection request to the MXCS using the Windows ODBC/MX driver. MXDM

specifies an IP address or the NonStop server Domain Naming Service (DNS) name and port
number that is defined when the Association server started up.

2. The ODBC/MX driver accesses an MXCS Association server on the NonStop system.
3. The Association server associates the client application with an available MXCS server for the

data source.
4. MXDM sends a connection request to the MXCS server that was assigned by the Association

server. After the user information is validated, a connection between MXDM and the SQL/MX
database is established.

Subsequently, you can view and administer the database and MXCS objects on the system.
For more information, see the HP NonStop SQL/MX Release 3.2 Connectivity Services Manual.
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2 Installing and uninstalling MXDM
This chapter discusses the following topics:

• “Supported version of SQL/MX” (page 15)

• “Contents of the installation package” (page 15)

• “Prerequisites” (page 15)

• “Installing MXDM” (page 16)

• “Uninstalling MXDM” (page 16)

Supported version of SQL/MX
The MXDM client can connect to systems running SQL/MX Release 3.2 or later.

Contents of the installation package
MXDM is available in 32-bit and 64-bit versions. You can install the 32-bit version of MXDM on
a 32-bit system. You can install either a 32-bit or a 64-bit version of MXDM on a 64-bit system.
The installer is available at $SYSTEM.ZMXODBC.
The MXDM32EX file includes the required contents of the 32-bit version of MXDM. The MXDM64EX
file includes the required contents of the 64-bit version of MXDM.
For information on the location of the installer, see the HP NonStop ODBC/MX Driver for Windows
for SQL/MX Release 3.2.
After obtaining either a MXDM32EX or a MXDM64EX file, rename the file to MXDM32EX.zip or
MXDM64EX.zip respectively, on the Windows client system.
MXDM32EX.zip contains the following files:

• setup.exe

• MXDMInstaller.msi

MXDM64EX.zip contains the following files:

• setup.exe

• MXDMInstaller-x64.msi

Prerequisites
The Windows client workstation must meet the following minimum requirements:

• At least 512 MB memory

• At least 10 MB disk space for installation and 64 MB free space

• Microsoft Windows XP, 32-bit or 64-bit Microsoft Windows Vista, or 32-bit or 64-bit Microsoft
Windows 7

• Microsoft .NET Framework 3.5

NOTE: MXDM requires .NET 3.5 runtime. If .NET 3.5 runtime is not available on your
system, running setup.exe automatically detects and installs the .NET 3.5 runtime.

• Windows ODBC/MX 3.2 client driver for Windows to connect to SQL/MX databases

32-bit version of MXDM requires the 32-bit Windows ODBC/MX client driver◦
◦ 64-bit version of MXDM requires the 64-bit Windows ODBC/MX client driver

Supported version of SQL/MX 15



NOTE: If you want to use RMXCI, you must install RMXCI and the JDBC T4 V32 driver.

Installing MXDM
This section discusses the following topics:

• “Installing the 32-bit version of MXDM” (page 16)

• “Installing the 64-bit version of MXDM” (page 16)

NOTE: If you are installing MXDM on Microsoft Windows Vista, and you are not logged on as
an administrator, you must install the files in alternate location, such as C:\user\your logon
name\NonStop SQLMX Database Manager. Microsoft Windows Vista allows only
administrators to install files in the C:\Program Files folder.

Installing the 32-bit version of MXDM
To install the 32-bit version of MXDM:
1. Save the MXDM32EX file on your Windows system, and rename the file to MXDM32EX.zip.
2. Extract the contents of the MXDM32EX.zip file into a temporary folder, such as C:\temp.
3. Double-click setup.exe or MXDMInstaller.msi to launch the NonStop SQL/MX Database

Manager Installer program.
4. Follow the instructions in the Installer program and complete the installation.

On a 32-bit system, the installer installs the application at: C:\Program Files\
Hewlett-Packard\NonStop SQLMX Database Manager\ unless you specify a different
location.
On a 64 bit system, the installer installs the application at: C:\Program Files (x86)\
Hewlett-Packard\NonStop SQLMX Database Manager\ unless you specify a different
location.

Installing the 64-bit version of MXDM
To install the 64-bit version of MXDM:
1. Save the MXDM64EX file on your Windows system, and rename the file to MXDM64EX.zip.
2. Extract the contents of the MXDM64EX.zip file into a temporary folder, such as C:\temp.
3. Double-click setup.exe or MXDMInstaller-x64.msi to launch the NonStop SQL/MX

Database Manager Installer program.
4. Follow the instructions in the Installer program and complete the installation.

The installer installs the application at: C:\Program Files\Hewlett-Packard\NonStop
SQLMX Database Manager\ directory unless you specify an alternate directory.

Uninstalling MXDM
To uninstall the 32-bit version of MXDM, select Start —> All Programs→NonStop SQL/MX Database
Manager→Uninstall NonStop SQL/MX Database Manager. You can also uninstall MXDM using
the Add and Remove Programs option in the Control Panel.
To uninstall the 64-bit version of MXDM, select Start —> All Programs→NonStop SQL/MX Database
Manager 64-bit→Uninstall NonStop SQL/MX Database Manager. You can also uninstall MXDM
using the Add and Remove Programs option in the Control Panel.
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Before uninstalling MXDM, you must consider the following:

• You do not have to uninstall the MXDM client before installing a newer version of MXDM.

• Uninstalling does not remove favorites or system definitions.

• If you uninstall from the Start menu, you are prompted to either repair or remove MXDM.
Selecting Repair is nondestructive, and verifies the program files. Selecting Remove begins
the uninstallation process.

Related Topics
“Obtaining version and build information” (page 38)
“Saving and importing system definitions” (page 45)
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3 Managing MXDM system objects
This chapter discusses the following topics:

• “Starting up MXDM” (page 18)

• “Adding a system” (page 18)

• “Connecting to a system” (page 19)

• “Disconnecting from a system” (page 21)

• “Using the Systems Tool” (page 21)

• “Editing a system definition” (page 23)

• “Copying a system definition” (page 23)

• “Removing a system” (page 24)

• “Testing a system definition” (page 24)

• “Setting the connection timeout” (page 24)

• “Exiting MXDM” (page 25)

Starting up MXDM
To start up the 32-bit version of MXDM, complete the following steps:
1. Launch MXDM in one of the following ways:

• Double-click the icon on your desktop.

• Select Start —> All Programs→NonStop SQLMX Database Manager→NonStop SQLMX
Database Manager.

2. Perform the steps described in “Adding a system” (page 18).
To start up the 64-bit version of MXDM, complete the following steps:
1. Launch MXDM in one of the following ways:

• Double-click the icon on your desktop.

• Select Start —> All Programs→NonStop SQLMX Database Manager 64-bit→NonStop
SQLMX Database Manager.

2. Perform the steps described in “Adding a system” (page 18).

Adding a system
Using MXDM, you must add a system definition for the NonStop system on which you want to
manage the database and MXCS objects. Subsequently, you can connect to the system and manage
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the objects. You can also use the Save Persistence option to save the system definition. During
subsequent attempts to connect to that system, the saved system definition is automatically retrieved.
To add a new system definition:
1. Open the Add System dialog in one of the following ways:

• In the navigation tree pane, right-click the My Systems folder, and select Add....

• Select Tools→Systems Tool, and click Add....
The Add System dialog appears.
Figure 2 (page 19) shows the Add System dialog.

Figure 2 Add System dialog

2. Enter the SQL/MX database connection details.
a. In the System Name field, enter a unique name to identify the system. The name can

include letters, numerals, the underscore character, and can be up to 32 characters. For
example, SYSTEM_1_A.

b. In the Port Number field, enter the port number on which the MXCS server is listening.
c. Click Add.

The system definition is added. After the system is added, the system name is displayed
in the navigation tree pane, under the My Systems folder.

NOTE: After a system is added, the system definition persists from session to session unless
you remove it.

Related Topics
“Connecting to a system” (page 19)
Terms
system definition

Connecting to a system
After adding a system definition, you can connect to the NonStop system. To connect:
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1. Open the Connect / Edit System dialog in one of the following ways:
• In the navigation tree pane, right-click the system name, and select Connect...

• In the navigation tree pane, click the system icon.

• Select Tools→Systems Tool, and double-click the system definition of the system to which
you want to connect. Alternatively, select the system definition, and click Edit...

The Connect / Edit System dialog appears. The saved system definition appears by default.
You can modify the system definition, if required. For information on modifying the system
definition, see “Adding a system” (page 18).

2. In the Connect / Edit System dialog, enter the following details:
a. Optional: In the Data Source field, enter the client data source name. If you do not specify

a data source, or the name of the client data source does not match the name of the
server data source, the client connects to the default server data source,
TDM_Default_DataSource. If the client data source exists, the fields in the dialog are
loaded from the client data source fields.

NOTE: If the data source that you specify already exists on the local system, the
remaining fields are automatically loaded into this dialog.

b. Mandatory: In the User Name field, enter the NonStop system user name. For example,
super.super.

c. Mandatory: In the Password field, enter the password of the NonStop system user.
d. Mandatory: In the Host field, enter the host name or the IP address of the NonStop system.
e. Mandatory: In the Port Number field, enter the port number on which the MXCS server

is listening.

NOTE: You can retain the port number that you specified while adding the system
definition.

f. Optional: In the Default Catalog field, if the catalog is not specified in your operations,
enter the default catalog to be used while writing a query. If the catalog is not specified,
MXDM selects NONSTOP_SYSTEM_NSK. If this catalog does not exist in the server, you
can create it. You must be the super.super user to create this catalog.

g. Optional: In the Default Schema field, enter the default schema to be used while writing
a query. If the schema is not specified, MXDM selects PUBLIC_ACCESS_SCHEMA. If this
schema does not exist in the database, you can create it. You must be the super.super
user to create this schema.

CAUTION: If the default catalog or schema name is a reserved word in SQL/MX, such
as USER, you must enclose the catalog or schema name within double quotes (“USER”).
Otherwise, the connection fails. For information on the list of reserved words, see the HP
NonStop SQL/MX Release 3.2 Reference Manual.

h. Mandatory: In the Driver field, select the version of the Windows ODBC/MX driver to
be used.

3. Click Connect.
MXDM attempts to establish a connection. If the connection cannot be established within the
specified timeout value, an error message appears. For information on changing the timeout
value, see “Setting the connection timeout” (page 24).

NOTE: You can test whether the system definition is valid. In the left pane, click the system name,
and in the right pane, enter the details required to connect to the system, and click Test. A dialog
appears indicating whether the test is successful.
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Related Topics
“Adding a system” (page 18)
“Disconnecting from a system” (page 21)
Terms
My Systems
Systems Tool
system definition

Disconnecting from a system
Disconnecting from a system closes all ODBC connections with that system. To disconnect from a
selected system:
1. Perform one of the following:

• In the navigation tree pane, right-click the connected system name, and select Disconnect.

• In the navigation tree pane, click the system icon (see “MXDM interface” (page 26)), and

select Disconnect( ) on the MXDM toolbar.
• Select Tools→Systems Tool. Select the required system definition, and click Disconnect.
The Confirm dialog box appears.

2. In the Confirm dialog, click Yes.
The system is disconnected.

After you have disconnected, the system icon and icon label change to reflect the disconnected
status. To disconnect from all systems, see “Exiting MXDM” (page 25).
Related Topics
“Using the Systems Tool” (page 21)
“Exiting MXDM” (page 25)
Terms
disconnect
Systems Tool

Using the Systems Tool
The Systems Tool feature enables you to define, add, edit, remove, duplicate, test, and connect to
an SQL/MX database.
To open Systems Tool, use one of the following methods:

• Click Systems Tool ( ) on the MXDM toolbar.

• From the menu bar, select Tools→Systems Tool.
The Systems Tool dialog appears.
Figure 3 (page 22) shows the Systems Tool dialog.
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Figure 3 Systems Tool dialog

Table 2 (page 22) describes the settings in the Systems Tool dialog.

Table 2 Systems Tool settings

DescriptionSetting

Displays the current state of the system definition (Connected or Disconnected).State

Displays the label that identifies this NonStop system. The system name can be up to 32
characters in length, and can consist of letters, numerals, and the underscore character.

System Name

Displays the name of the client data source. If you do not specify a data source, or the
name of the client data source does not match the name of the server data source, the client

Data Source

connects to the default server data source, TDM_Default_DataSource. If the client data
source exists, the value of the other fields in the dialog are loaded from the client data
source fields.

Displays the user name.User Name

Displays the DNS name or IP address of the target NonStop system.Host

Displays the ODBC/MX server port number.Port Number

Displays the default catalog to be used when writing a query.Default Catalog

Displays the default schema to be used when writing a query.Default Schema

Displays the ODBC/MX driver to be used.DriverString

CAUTION: If the default catalog or the default schema is a reserved word in SQL/MX (for
example, USER), you must enclose the catalog or schema name in double quotes (“USER”).
Otherwise, the connection fails. For information on reserved words, see the SQL/MX Release 3.2
Reference Manual.

Table 3 (page 23) describes the Systems Tool options.
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Table 3 Systems Tool options

DescriptionSetting

Enables you to test a selected system and displays the results in the Connection Test Result
dialog. Test is enabled when you select one or more systems.

Test

Enables you to launch the Connect / Edit System dialog with the current settings of the
selected system. Edit is enabled when you select one or more systems.

Edit...

Enables you to launch the Add dialog.Add...

Enables you to launch the Add System Like dialog with the current settings of the selected
system. You can use these settings to add a new system. Add Like is enabled when you
select only one system.

Add Like...

Enables you to remove the selected system. The selected system can be connected or
disconnected. A Confirm dialog appears before the selected system is removed.

Remove

Enables you to disconnect a system. Disconnect is enabled when you select one or more
systems. A Confirm dialog appears before the selected systems are disconnected.

Disconnect

Enables you to close the Systems Tool.Close

Terms
system
data source
TDM_Default_DataSource

Editing a system definition
If you want to edit a system definition of a system, which is currently connected, you must first
disconnect from the system.
To edit a system definition:
1. Disconnect from the system. For information on how to disconnect, see “Disconnecting from

a system” (page 21).
2. Use one of the following methods to open the Connect / Edit System dialog:

• In the navigation tree pane, right-click the required system name, and select Connect...
or Edit...

• Select Tools→Systems Tool. Select the required system definition, and click Edit...
3. In the Connect / Edit System dialog, enter the data. For information on the fields, see “Adding

a system” (page 18).
4. Click Save to save the newly created system definition, or click Connect to connect to the

system.
Related Topics
“Disconnecting from a system” (page 21)

Copying a system definition
You can add a system by copying an existing system definition. To add a new system definition
using an existing system definition:
1. Open the Add System Like dialog using one of the following methods:

• In the navigation tree pane, right-click the name of the system whose system definition
you want to copy, and select Add Like....

• Select Tools→Systems Tool from the menu bar. Select the system definition that you want
to copy, and click Add Like....

The Add System Like dialog appears.
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2. In the Add System Like dialog:
a. Specify a new name in the System Name field.
b. Retain or modify the information specified in the fields of the selected system. For more

information on the fields, see “Adding a system” (page 18).

NOTE: If the data source that you specify already exists on the local system, the
remaining fields are automatically loaded into this dialog.

c. Click Add.
The new system definition is added.

Removing a system
To remove a system from MXDM:
1. Perform one of the following steps:

• In the navigation tree pane, right-click the system name, and select Remove.

• Select Tools→Systems Tool. Select one or more systems that you want to remove, and
click Remove.

The Confirm dialog appears.
2. In the Confirm dialog box, click Yes.

The system definitions are removed.

Testing a system definition
To test the system definition:
1. Select the system in the navigation tree pane.

The Connect/Edit System fields appear in the right pane.
2. Enter the password.
3. Click Test.

The Connection Test Result dialog appears, indicating whether the system definition is valid
or not.

NOTE: Testing the system definition does not establish a connection to the system.

Terms
system definition
My Systems

Setting the connection timeout
If you frequently receive connection timeout errors, you must increase the connection timeout value.
The ODBC/MX driver default for connection timeout is 60 seconds. When a system is heavily
loaded, establishing an ODBC connection can take more than 60 seconds, and MXDM connections
might time out. Therefore, the default timeout value for MXDM is set to 180 seconds, and overrides
the default set in the ODBC/MX client data source. You can modify the default MXDM timeout
value.
The following are the connection timeout rules:
• The default for the connection timeout option is 180 seconds (3 minutes).

• The range is an integer value from 0 to 2,147,483,647 seconds.

• Setting a value of 0 indicates no timeout.

• Setting the connection timeout does not address timeouts that might occur on query execution.
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To set the connection timeout:
1. Perform one of the following:

• On the MXDM toolbar, click Options ( )

• Select Tools→Options....
The Options dialog appears.

2. Select Framework under General.
3. In the right pane of the Options dialog, enter the number of seconds that you want to specify

for the connection timeout.
Figure 4 (page 25) shows the Options dialog.

Figure 4 Options dialog

4. Click OK.
The new timeout value is set.

Related Topics
“Adjusting the display of an area” (page 31)
“Using the MXDM toolbar” (page 29)

Exiting MXDM
To disconnect from a single active session without exiting MXDM, right-click the system name in
the left pane and select Disconnect. For more information, see “Disconnecting from a system”
(page 21).
To exit MXDM, select File→Exit. Exiting the application securely disconnects all active sessions.
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4 Navigating MXDM
This chapter discusses the following topics:

• “MXDM interface” (page 26)

• “MXDM banner” (page 27)

• “Using the MXDM menus” (page 27)

• “Using the MXDM toolbar” (page 29)

• “Selecting an area” (page 30)

• “Adjusting the display of an area” (page 31)

• “Using the My Favorites pane” (page 32)

• “Using the navigation tree” (page 33)

• “Using the right pane” (page 35)

• “Working with windows, tabs, and panes” (page 36)

MXDM interface
Figure 5 (page 26) shows the MXDM interface.

Figure 5 MXDM interface

Table 4 (page 26) describes the parts in the MXDM interface.

Table 4 Parts of the MXDM interface

DescriptionLabelNumber

The MXDM banner displays information about the
system, user, and the default schema. For more
information, see “MXDM banner” (page 27).

MXDM banner1

Displays the menus available in MXDM. For more
information, see “Using the MXDM menus” (page
27)

Menu bar2

Displays the tools available in MXDM. For more
information, see “Using the MXDM toolbar” (page
29)

Tool bar3

Displays the objects in the selected area.Selected tab4
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Table 4 Parts of the MXDM interface (continued)

DescriptionLabelNumber

Displays the selected area.Selected area5

Favorites appear in the My Favorites pane. For more
information, see “Using the My Favorites pane”
(page 32).

My Favorites pane6

The navigation tree displays all the systems that you
have added using the Systems Tool. For more

Navigation tree pane7

information, see “Using the navigation tree” (page
33).

The right pane displays information about the
selected objects in the My Favorites pane or in the

Right pane8

navigation tree. For more information, see “Using
the right pane” (page 35)

Displays the areas available in MXDM.Area tabs available9

The MXDM status bar.Status bar10

Related Topics
“Using the MXDM toolbar” (page 29)
“MXDM banner” (page 27)
“Using the navigation tree” (page 33)
“Using the right pane” (page 35)
“Using the My Favorites pane” (page 32)
“Using the MXDM menus” (page 27)

MXDM banner
The MXDM banner appears above the right pane. Figure 6 (page 27) shows the MXDM banner.

Figure 6 MXDM banner

The banner displays the following information:

• The name of the system

• The host and port information for the current connection

• The currently connected data source

• The user name

• The default schema
Related Topics
“MXDM interface” (page 26)

Using the MXDM menus
MXDM includes the following menus:

• “Using the File menu options” (page 28)

• “Using the Edit menu options” (page 28)

• “Using the Tools menu options” (page 28)

• “Using the Windows menu options” (page 29)

• “Using the Help menu options” (page 29)
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Using the File menu options
Table 5 (page 28) describes the File menu options.

Table 5 File menu options

DescriptionOption

Imports persistence data from a file that was saved using MXDM.

NOTE: All the current settings are replaced by the settings in the imported file.

Import Persistence

For more information, see “Saving and importing system definitions” (page 45).

Saves the current configuration.Save Persistence

Saves the configuration to any file. You can use the Export Persistence option to export a
specific configuration to other users in the organization. For more information, see “Saving
and importing system definitions” (page 45).

Export Persistence

Securely disconnects all active sessions. For more information, see “Exiting MXDM” (page
25).

Exit

Related Topics
“MXDM interface” (page 26)
“Saving and importing system definitions” (page 45)
“Exiting MXDM” (page 25)
“Using the MXDM menus” (page 27)
Terms
menu bar
persistence file
system definition

Using the Edit menu options
Table 6 (page 28) describes the Edit menu options.

Table 6 Edit menu options

DescriptionOption

Cancels the last operation.Undo

Reverses the last Undo command.Redo

Removes the selected text and copies it to the clipboard.Cut

Copies the selected text to the clipboard without removing it.Copy

Inserts the selected text at the cursor position.Paste

Highlights all text.Select All

Related Topics
“Using the MXDM menus” (page 27)

Using the Tools menu options
Table 7 (page 29) describes the Tools menu options.
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Table 7 Tools menu options

DescriptionOption

Launches the SQL Whiteboard. For more information on SQL Whiteboard, see “Using the
SQL Whiteboard” (page 98).

SQL Whiteboard

Launches RMXCI. For more information on RMXCI, see “Launching the NonStop SQL/MX
Remote Conversational Interface” (page 96).

SQL/MX Remote
Conversational Interface

Opens the Systems Tool dialog. For more information on Systems Tool, see “Using the Systems
Tool” (page 21).

Systems Tool

Opens the Options dialog. For more information, see the following:Options...
• “Adjusting the display of an area” (page 31)

• “Setting the connection timeout” (page 24)

• “Setting Auto Logon options” (page 97)

Related Topics
“Using the MXDM menus” (page 27)
“Using the MXDM toolbar” (page 29)

Using the Windows menu options
Table 8 (page 29) describes the Windows menu options.

Table 8 Windows menu options

DescriptionOption

Displays the Windows Manager.Windows Manager...

Closes all open windows except the main window.Close All

Related Topics
“Using the MXDM menus” (page 27)

Using the Help menu options
Table 9 (page 29) describes the Help menu options.

Table 9 Help menu options

DescriptionOption

Opens the MXDM online help and displays the Contents tab.Contents

Opens the MXDM online help and displays the Index tab.Index

Opens the MXDM online help and displays the Search tab.Search

Displays the About dialog. For more information, see “Obtaining version and build information”
(page 38).

About...

Related Topics
“Using the MXDM menus” (page 27)

Using the MXDM toolbar
MXDM includes tools in the toolbar that enable you to perform many common operations.
Table 10 (page 30) describes the MXDM tools.
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Table 10 MXDM tools

DescriptionTool

Displays the Connect / Edit System dialog and enables you to connect to a system or
modify a system definition. For more information, see “Connecting to a system” (page
19).

Enables you to disconnect the selected system. For more information, see “Disconnecting
from a system” (page 21).

Enables you to define, add, edit, remove, duplicate, test, and open connections to a
SQL/MX database using MXDM. For more information, see “Using the Systems Tool”
(page 21).

Enables you to use system definitions from a saved persistence file. For more information,
see “Saving and importing system definitions” (page 45).

Enables you to save the current settings. For more information, see “Saving and importing
system definitions” (page 45).

Enables you to remove the selected text and copy to the clipboard. For more information,
see “Using the Edit menu options” (page 28).

Enables you to copy the selected text to the clipboard. For more information, see “Using
the Edit menu options” (page 28).

Enables you to insert the selected text at the cursor position. For more information, see
“Using the Edit menu options” (page 28).

Launches the SQL Whiteboard. For more information, see “Introduction to the SQL
Whiteboard” (page 98).

Launches RMXCI. For more information, see HP NonStop SQL/MX Remote
Conversational Interface (RMXCI) Guide or “Launching the NonStop SQL/MX Remote
Conversational Interface” (page 96).

Enables you to configure options and views. For more information, see “Using the Tools
menu options” (page 28).

Opens the Windows Manager that lists all the open windows and provides functions
to display and close these windows. For more information, see “Cloning tabs and
managing multiple open windows” (page 36).

Selects the next higher object in the navigation tree hierarchy. For example, if a table
is currently selected, clicking Go to Parent selects the table folder. Clicking the icon
again selects the schema icon.

Selects the previous object in the navigation tree hierarchy. If no other objects exist,
Go to Previous is disabled.

Selects the next object in the navigation tree hierarchy. If no other objects exist, Go to
Next is disabled.

Displays the online help.

Related Topics
“MXDM interface” (page 26)

Selecting an area
In MXDM Release 3.2, Database and Connectivity areas are available. The Database area includes
all the database objects that you can view and manage. The Connectivity area includes the MXCS
objects that you can view and manage. To select an area, click the required tab below the
navigation tree pane. Table 11 (page 31) describes the areas available in SQL/MX Release 3.2.
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Table 11 Supported areas

DescriptionArea

Provides information about the database objects. For more
information, see “Viewing database objects” (page 47).

Database

Provides information about MXCS objects. For more information,
see “Managing MXCS objects” (page 76)

Connectivity

MXDM displays the currently selected area below the menu bar “MXDM interface” (page 26).
When you select an area, MXDM displays the characteristics of that area for all connected systems.
Related Topics
“Adjusting the display of an area” (page 31)
Terms
area

Adjusting the display of an area
By default, MXDM displays all the supported areas. However, you can choose to display or hide
an area by using the Options menu.

To display the Options menu, click Options( ) on the MXDM toolbar, or select Tools→Options....
The Options dialog appears.
Figure 7 (page 31) shows the Options dialog.

Figure 7 Show/Hide Area options

To hide an area:
1. Clear the option for the required area in the Show/Hide Area Options pane.
2. Click OK.
To show an area that is hidden:
1. Select the option for the required area in the Show/Hide Area Options pane.
2. Click OK.
Related Topics
“Selecting an area” (page 30)
Terms
area
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Using the My Favorites pane
MXDM enables you to create favorites and organize them in folders. Subsequently, you can use
favorites to easily navigate to the required objects.
Favorites appear in the My Favorites pane.

Creating a folder to store favorites
In the My Favorites pane, you can create folders at the top level or folders within folders:
1. In the My Favorites pane, right-click the My Favorites folder and select New Folder...

NOTE: To create a folder within an existing folder, right-click the folder, and select New
Folder...

2. Assign a name for the folder, and click OK.

Creating a favorite
To create a favorite, use one of the following methods:

• Drag and drop an object into the My Favorites pane, as described in the following procedure:
1. Optional: If you want to create a favorite within a folder in the My Favorites pane, you

must create the folder first. For information on creating a folder, see “Creating a folder
to store favorites” (page 32).

2. In the navigation tree pane, navigate to the object.
3. Click and drag the object into the My Favorites pane. Drop the object at the required

location. A dialog prompts you to enter a name for the favorite.
4. Assign a name.
5. Click OK.

The favorite is created.

• Right-click an object and use the context menu options to create the favorite, as described in
the following procedure:
1. Optional: If you want to create a favorite within a folder in the My Favorites pane, you

must create the folder first. For information on creating a folder, see “Creating a folder
to store favorites” (page 32).

2. In the navigation tree pane, navigate to the object.
3. Right-click the object, and select Add To Favorites... A dialog prompts you to enter a

name for the favorite.
4. Assign a name.
5. Click OK.

The favorite is created.

Using a favorite
To use a favorite, select the favorite in the My Favorites pane. Information about the favorite appears
in the right pane.

Viewing a list of favorites
To view a list of current favorites and folders in My Favorites, including the path to each favorite,
double-click the My Favorites folder in the My Favorites pane.
To view a list of favorites contained in a folder, including the path to each favorite, double-click
the folder.
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Removing a favorite
To remove a favorite, right-click the favorite, and select Remove.

Removing a favorites folder
To remove a folder, right-click the folder, and select Remove. The folder and all favorites contained
within it are removed.

Considerations
You can create a favorite and store it in a folder. You can save your favorites and other personalized
client settings. However, you cannot perform the following actions:
• Move a favorite from one folder to another folder.

• Move a favorite that already exists under My Favorites into a folder.

• Rename the favorite folder or a favorite object.

Using the navigation tree
The navigation tree pane is available in the left pane of the MXDM GUI. For more information,
see “MXDM interface” (page 26). The navigation tree displays all the systems that you have added
using the Systems Tool. System icons appear under the My Systems folder. A green check box next
to the system name indicates that the system is connected.
Figure 8 (page 33) shows the navigation tree with sample system names.

Figure 8 Navigation tree
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When you select the Database area, you can view the database objects on the connected systems,
in the navigation tree.
The right pane displays more details about any object selected in the navigation tree pane. For
more information, see “Using the right pane” (page 35).
To add a new system, click Add... at the bottom of the right pane. If systems have been added
previously, the right pane displays the active systems.
To display the options related to My Systems, right-click the My Systems folder. Table 12 (page
34) describes the options.

Table 12 Options related to the My Systems folder

DescriptionOption

Refreshes an object and its child objects in the navigation tree.Refresh

Adds a new system. For information on adding a system, see “Adding a system” (page 18).Add...

To display the options related to a system that is connected, right-click the system name under My
Systems. Table 13 (page 34) describes the options.

Table 13 Options related to a connected system

DescriptionOption

Creates a shortcut for the object under My Favorites. You can launch the New Favorite dialog
to provide an alias for the object. For more information, see “Using the My Favorites pane”
(page 32).

Add to Favorites...

Refreshes the object and its child objects in the navigation tree.Refresh

Closes the connection with the system. For more information, see “Disconnecting from a system”
(page 21).

Disconnect

Tests whether the system definition is valid. For more information, see “Testing a system
definition” (page 24).

Test

Adds a system whose system definition is similar to the system definition of the selected system.
For more information, see “Copying a system definition” (page 23).

Add Like...

Removes a selected system. For more information, see “Removing a system” (page 24).Remove

Launches the OSM Event Viewer in the default browser. You can use the search criteria to
search for events in the event log.

OSM Event Viewer

To display the options for a disconnected system, right-click the system name under My Systems.
Table 14 (page 34) describes the options.

Table 14 Options related to a disconnected system

DescriptionOption

Creates a shortcut to the selected system. For more information, see “Using the My Favorites
pane” (page 32).

Add to Favorites...

Refreshes the object and its child objects in the navigation tree.Refresh

Establishes a connection with the system by using the values defined in the system definition.
For more information, see “Connecting to a system” (page 19).

Connect...

Edits the system definition of a disconnected system. For more information, see “Editing a
system definition” (page 23).

Edit...

Adds a system whose system definition is similar to the system definition of the selected system.
For more information, see “Copying a system definition” (page 23).

Add Like...

Removes a selected system definition. For more information, see “Removing a system” (page 24).Remove

34 Navigating MXDM



Related Topics
“MXDM interface” (page 26)
“Adding a system” (page 18)
“Using the My Favorites pane” (page 32)
“Using the right pane” (page 35)
“Disconnecting from a system” (page 21)
Terms
My Systems

Using the right pane
The right pane displays information about the selected objects in the My Favorites pane or in the
navigation tree. Table 15 (page 35) describes the options displayed in the right pane when you
select the My Systems folder.

Table 15 Options in the right pane for a connected system

DescriptionOption

Tests a selected system and displays the results in the Connection Test Result dialog. Test is
enabled when you select one or more systems.

Test

Edits the system definition of a disconnected or an inactive system. Edit... is enabled when you
select one or more disconnected systems.

Edit...

Adds a new system. Add... is always enabled.Add...

Adds a system whose system definition is similar to the system definition of the selected system.
Add Like... is enabled when you select only one system.

Add Like...

Removes a selected system definition. You must confirm the removal in the Confirm dialog.Remove

Closes the connection with the system. In the Confirm dialog, you must confirm whether you
want to disconnect the system.

Disconnect

When a table is displayed in the right pane, another set of options appears at the bottom of the
right pane. Table 16 (page 35) describes the options.

Table 16 Options in the right pane when a table is displayed

DescriptionOption

Copies the table data to the Windows clipboard. For more information, see “Copying data”
(page 44).

Data to Clipboard

Opens a browser to display the data in a tabular format. For more information, see “Copying
data” (page 44).

Data to Browser

Displays the data in a Microsoft Excel application. For more information, see “Copying data”
(page 44).

Data to Spreadsheet

Copies the data to a file in Comma Separated File (CSV) and HTML formats. For more
information, see “Copying data” (page 44).

Data to File

Related Topics
“MXDM interface” (page 26)
“Copying data” (page 44)
Terms
right pane
navigation tree pane
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Working with windows, tabs, and panes
MXDM provides all of the conventional user-interface controls available in other Windows
applications. MXDM windows can be resized within permissible limits. When a window is resized,
graphical objects in a window get resized, if necessary.
To display information, MXDM provides the following features:
• Ability to clone windows and tabs, and manage multiple open windows from one dialog. For

more information, see “Cloning tabs and managing multiple open windows” (page 36).
• Ability to expand and collapse window panes. For more information, see “Expanding and

collapsing panes” (page 36)).

Cloning tabs and managing multiple open windows
MXDM enables you to clone the information available in some tabs, in a new window. A copy of
the selected tab and its information is created in a new window. MXDM also supports launching
multiple cloned windows simultaneously. As a result, you can launch multiple windows, resize the
windows, and compare the data in those windows. Cloning data and launching multiple windows
are useful when you want to monitor multiple systems or multiple aspects of the same system
simultaneously.
To clone a tab, double-click the tab name, or right-click a tab name and select Clone in Window.
To manage multiple windows, MXDM includes the Windows Manager that lists all the open windows,
and provides functions to display and close these windows.

To open the Windows Manager, click Windows Manager ( ) on the MXDM toolbar, or select
Windows→Windows Manager....
Table 17 (page 36) describes the Windows Manager options.

Table 17 Windows Manager options

DescriptionOption

Moves the selected windows to the front.Activate

Closes the selected windows. However, the main window remains open.Close Window(s)

Displays the main window.Main Window

Closes Windows Manager.OK

Expanding and collapsing panes
Some MXDM windows contain controls that enable you to resize, expand, and collapse a pane
or part of a pane.
Figure 9 (page 37) shows the controls.
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Figure 9 Window controls
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5 Performing basic MXDM operations
This chapter discusses the following topics:

• “Obtaining version and build information” (page 38)

• “Resolving errors and error messages” (page 38)

• “Sorting and moving data columns” (page 38)

• “Working with data grids” (page 40)

• “Copying data” (page 44)

• “Saving and importing system definitions” (page 45)

Obtaining version and build information
The version and build information appears in the About NonStop SQL/MX Database Manager
dialog. To open the dialog, select Help→About... The About NonStop SQL/MX Database Manager
dialog displays the current build information.
Figure 10 (page 38) shows the About NonStop SQL/MX Database Manager dialog.

Figure 10 About MXDM dialog

Resolving errors and error messages
For information on error messages, see the HP NonStop SQL/MX Release 3.2 Messages Manual.
Related Topic
“Related documentation” (page 8)

Sorting and moving data columns
You might want to see rows in an MXDM display (for example, a list of schemas) grouped on the
basis of the information type. You can sort the displayed data in some tabs based on column
values. You can also change the order of the columns by dragging a column heading to the left
or right.
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To change the sort order of a displayed column, click the heading of the column that you want to
sort. A triangle appears at the right indicating the order.
Figure 11 (page 39) shows the column heading with the triangle.

Figure 11 Column sorting

To sort multiple columns, use the Ctrl key. MXDM numbers the selected columns and sorts the data
based on the order in which the columns are selected.
To move a displayed data column, drag the column heading and release at the required position.
Figure 12 (page 40) shows the changed order of Process Name and Service Type columns.
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Figure 12 Changed order of columns

Working with data grids
This section discusses the following topics:

• “Introduction to data grids” (page 40)

• “Obtaining row details for a data grid” (page 41)

• “Copying data grid information” (page 42)

• “Customizing the data grid” (page 42)

• “Searching the data grid” (page 43)

Introduction to data grids
The SQL Whiteboard Statement Details pane and the Report Results pane display information in
a data grid. The data grid is a simple table with columns that display data. You can manipulate
this data. Data grids enable you to perform the following tasks:

• Obtain details about a specific cell or a row.

• Issue commands.

• Sort data within a column.

• Rearrange columns.

• Copy cell or row information.

• Customize the display of information.

• Search for information in the grid.
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Some MXDM tabs, such as the tabs in the Database area, do not provide data grids. You can sort
single columns and copy the data in these tabs. However, you cannot obtain row details, search
for items, or display context menus.
Related Topics
“Obtaining row details for a data grid” (page 41)
“Copying data grid information” (page 42)
“Customizing the data grid” (page 42)
“Searching the data grid” (page 43)
Terms
data grid

Obtaining row details for a data grid
To obtain information about any row in a data grid, use one of the following methods:

• Right-click a cell in the row, and select Row Details.

• Double-click any cell in the data grid.
The Row Details dialog appears. Figure 13 (page 41) shows the Row Details dialog for alerts.

Figure 13 Row Details dialog

The Row Details dialog displays all possible column information, whereas the data grid displays
only the grid columns that are currently configured using the Show/Hide Grid Columns command.
Arrows at the top of the dialog enable you to display details for other rows in the data grid without
exiting the Row Details dialog.
Figure 14 (page 42) displays the arrows that you can use to view details in multiple rows.
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Figure 14 Viewing multiple rows in the data grid

Related Topics
“Introduction to data grids” (page 40)
“Customizing the data grid” (page 42)

Copying data grid information
To copy the data in cells, select the cells you want to copy, and then right-click and select Copy.
Figure 15 (page 42) shows how you can copy grid information.

Figure 15 Copying grid information

To copy data in noncontiguous cells, use the Ctrl key.
The cell values are copied into the Windows clipboard. From there, you can paste them into other
Windows applications.
Related Topics
“Introduction to data grids” (page 40)
“Customizing the data grid” (page 42)

Customizing the data grid
You can customize the columns in data grids. Table 18 (page 43) describes how you can customize
the columns.
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Table 18 Procedures to customize the data grid

Do thisTo

Show or hide columns 1. Right-click a column heading in any data grid, and select Show/Hide Grid
Columns. The Show/Hide Grid Columns dialog appears.

2. Select the columns that you want to display, and click OK.

NOTE: Click Defaults at any time to restore the default column selections.

Use one of the following methods:Change the order of displayed
columns • In the Show/Hide Grid Columns dialog, select a column, then click the up or

down arrows to change the position of the column:

• Click OK.

• In the data grid, click and drag the column to a new position. For more
information, see “Sorting and moving data columns” (page 38).

See “Sorting and moving data columns” (page 38).Sort information in the columns

Changes you make persist across MXDM sessions.
Related Topics
“Introduction to data grids” (page 40)

Searching the data grid
To search for a string, select any cell in the data grid, and then type the first few characters of a
string. MXDM locates the first occurrence of a cell within the same column that contains the search
string. Press Alt + ↓ and Alt + ↑ to switch to the next or previous occurrence of the search string.
Figure 16 (page 44) shows how you can search for information in the grids.
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Figure 16 Searching for information

Related Topics
“Introduction to data grids” (page 40)

Copying data
You can copy data to different locations, and use the data for comparisons and analysis. This
section discusses the following topics:

• “Copying data to the clipboard” (page 44)

• “Copying data to a file” (page 44)

• “Copying data to a spreadsheet” (page 44)

• “Copying data to a browser” (page 45)

Copying data to the clipboard
Data to Clipboard saves the data to the clipboard. Each value is a double-quoted string.
Subsequently, you can paste the clipboard data to any Microsoft Windows document, such as,
Microsoft Excel, Microsoft Notepad, or Microsoft Word.

Copying data to a file
Data to File displays a window to copy the contents to a file. You can save the data in the Comma
Separated File Format (CSV) and HTML formats.

Copying data to a spreadsheet
Data to Spreadsheet transparently copies the table data to a temporary local file in standard HTML
table format, and then executes the file. A Microsoft Excel file that includes the table data launches.
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Copying data to a browser
Data to Browser invokes Internet Explorer or a default browser that displays the table data. The
data is copied internally in standard HTML format. Internet Explorer is then invoked on a temporary
HTML file. You can then use Internet Explorer to save the contents.

NOTE: If the table has no data, the Copy buttons are disabled.

Saving and importing system definitions
MXDM enables you to save multiple system definitions and share them with other client workstations.
System definitions are saved in a persistence file. The persistence file is a binary file that contains
state and user preference information. The persistence file includes the following information:

• System definitions

• User-specified options

• Favorites

• Statements executed from the SQL Whiteboard

• SQL Whiteboard layout information
The persistence file is located in the default directory for your Windows user name. For example,
if your user name is janedoe, depending on the value of your HOME environment variable in
your workstation, the persistence file is located at:
Windows XP: C:\Documents and Settings\janedoe\MXDatabaseManager
Windows Vista: C:\Users\janedoe\MXDatabaseManager
However, if a different directory is specified for the HOME environment variable of your workstation,
you can save the persistence file to a different location.
To save the currently defined system definitions, perform one of the following:

• On the MXDM toolbar, click Save Persistence ( ).

• Select File→Save Persistence.

NOTE: You do not need to save the persistence file. The persistence file is saved automatically
when you exit MXDM.

You can save system definitions in a data file. Subsequently, you can transfer the information to
the persistence file. To export a copy of the currently defined system definitions:
1. Select File→Export Persistence.

The Export Persistence dialog appears.
2. Specify a file name and a location for the copied persistence file.
3. Click OK.

The file is exported with the .mxdm extension.

You can import system definitions from a saved .mxdm file. When you import a persistence file,
active systems are disconnected. To import system definitions from a saved .mxdm file:
1. Perform one of the following:

• Click Import Persistence ( ) on the MXDM toolbar.

• Select File→Import Persistence.
The Import Persistence dialog appears.

2. Select the previously exported .mxdm file, and click Open.
The Confirm dialog appears.
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3. Click Yes.
MXDM copies the information from the .mxdm file into the persistence file and prompts you
to reconnect if you were connected to active systems.

Related Topics
“Using the MXDM menus” (page 27)
“Using the MXDM toolbar” (page 29)
Terms
persistence file
system definition
Systems Tool
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6 Viewing database objects
This chapter discusses the following topics:

• “Viewing catalogs and their objects” (page 47)

• “Viewing schemas” (page 49)

• “Viewing table properties” (page 52)

• “Viewing schema views and their properties” (page 64)

• “Viewing procedures and their properties” (page 67)

• “Viewing SQL/MP aliases and their properties” (page 71)

• “Viewing table statistics and their properties” (page 72)
For information on the database objects, see the HP NonStop SQL/MX Release 3.2 Reference
Manual.

Viewing catalogs and their objects
To view the catalogs on a system:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Database.

MXDM displays a list of existing systems.
3. Expand the contents of the system in the navigation tree.

The list of catalogs appear.
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4. Click a catalog.
The following tabs related to the catalog appear in the right pane:

• Attributes

• Registrations

• Schemas

• DDL
Figure 17 (page 48) shows the catalog properties.

Figure 17 Catalog properties

Viewing catalog attributes
To view the catalog attributes and their values:
1. In the navigation tree, select the catalog.
2. In the right pane, click Attributes.

The following attributes and their values appear:

• Name — The name of the catalog.

• Metadata UID — Internal UID number of the catalog.

• Location — Disk volume where the catalog is located.

Viewing catalog registrations
To view the systems where the catalog is registered:
1. In the navigation tree, select the catalog.
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2. In the right pane, click Registrations.
The following details appear:

• System — The system where this catalog is registered.

• Location — The physical volume where the catalog is registered.

• Rule — The replication rule. The rule can be automatic or manual.

Viewing schemas within a catalog
To view the schemas in the catalog:
1. In the navigation tree, select the catalog.
2. In the right pane or the Schemas folder within the catalog, click Schemas.

The following details appear:

• Name — The name of the schema.

• Owner — The user who created the schema.

• Version — The schema version.

• Location — The physical volume where the schema is located.

• Metadata UID — The Internal UID number of the schema.

Viewing catalog DDL
To view the catalog DDL:
1. In the navigation tree, select the catalog.
2. In the right pane, click DDL.

The DDL statement appears.

Viewing schemas
To view the schemas in a catalog:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Database.

MXDM displays a list of existing systems.
3. Expand the contents of the system in the navigation tree.

The list of catalogs appear.
4. Expand the contents of a catalog.

The list of schemas appear.
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5. Click a schema.
The following tabs related to the schema appear in the right pane:

• Attributes

• Tables

• Views

• Procedures

• SQL/MP Aliases

• DDL
Figure 18 (page 50) shows the schema properties.

Figure 18 Schema properties

Viewing schema attributes
To view the schema attributes and their values:
1. In the navigation tree, select the schema.
2. In the right pane, click Attributes.

The Attributes tab displays the following attributes and their values:

• Name — The name of the schema.

• Metadata UID — The internal UID number of the schema.

• Location — The physical volume where the schema is located.

• Owner — The user who created the schema.

• Version — The schema version.
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Viewing tables within a schema
To view the tables within a schema:
1. In the navigation tree, select the schema.
2. In the right pane or the Tables folder within the schema, click Tables.

The following details appear:

• Name — The name of the table. Each table name is a hyperlink. Clicking the hyperlink
displays the details of the table.

• Metadata UID — The internal UID number of the table.

• Creation Time: — The time and date when the table was created. The Creation Time:
attribute is in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Redefinition Time: — The time and date when the table was last redefined. The Redefinition
Time: attribute is in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

Viewing schema views
To view the schema views:
1. In the navigation tree, select the schema.
2. In the right pane or the Views folder within the schema, click Views.

The following details appear:

• Name — The name of the view. Each view name is a hyperlink. Clicking the hyperlink
displays the details of the view.

• Metadata UID — The internal UID number of the view.

• Creation Time: — The time and date when the view was created. The Creation Time:
attribute is in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Redefinition Time: — The time and date when the view was last redefined. The Redefinition
Time: attribute is in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

Viewing schema procedures
To view the schema procedures:
1. In the navigation tree, select the schema.
2. In the right pane or the Procedures folder within the schema, click Procedures.

The following details appear:

• Name — The name of the procedure. Each procedure name is a hyperlink. Clicking the
hyperlink displays the details of the procedure.

• Metadata UID — The internal UID number of the procedure.

• Creation Time: — The time and date when the procedure was created. The Creation Time:
attribute is in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Redefinition Time: — The time and date when the procedure was last redefined. The
Redefinition Time: attribute is in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

Viewing SQL/MP aliases within a schema
To view the SQL/MP aliases that belong to a schema:
1. In the navigation tree, select the schema.
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2. Do one of the following:
• In the right pane, click SQL/MP Aliases.

• Within the schema, click the SQL/MP Alias folder.
The following details appear:

• Name — The name of the SQL/MP alias. Each SQL/MP alias name is a hyperlink.
Clicking the hyperlink displays the details of the SQL/MP alias.

• Metadata UID — The internal UID number of the SQL/MP alias.

• Creation Time: — The time and date when the SQL/MP alias was created. The Creation
Time: attribute is in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Redefinition Time: — The time and date when the SQL/MP alias was last redefined. The
Redefinition Time: attribute is in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

Viewing schema DDL
To view the DDL of the schema:
1. In the navigation tree, select the schema.
2. In the right pane, click DDL.

In the right pane, a SQL statement to create the schema appears.

Viewing table properties
To view the table properties in a schema:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Database.

MXDM displays a list of existing systems.
3. In the navigation tree, expand the contents of the system.

The list of catalogs appears.
4. Expand the contents of a catalog.

The list of schemas appears.
5. Expand the contents of a schema.

The Tables folder appears.
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6. Select a table.
The right pane displays the following tabs:

• Columns

• Primary Key

• Hash Key

• Store Order

• Check Constraints

• Unique Constraints

• Foreign Keys

• Attributes

• Partitions

• Related Objects

• DDL

• Statistics

• Privileges
Figure 19 (page 53) describes the table properties.

Figure 19 Table properties

Additionally, each table in the navigation tree contains two folders: Indexes and Triggers. The
Indexes folder contains the list of indexes of the specified table. For more information on indexes,
see “Displaying table indexes and their properties” (page 58). The Triggers folder contains a list
of triggers on the specified table. For more information on triggers, see “Displaying table triggers
and their properties” (page 61).

Viewing table column properties
To view the table column properties:
1. In the navigation tree, select the table.
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2. In the right pane, click Columns.
The following details appear:

• Primary Key — An icon or special symbol to indicate that the column is part of the primary
key. If the column is not a part of the primary key, the field is blank.

• Column Name — The name of the column (string).

• Data Type: — The SQL data type of the column.

• Nullable: — If a column is NOT NULL or NOT NULLABLE NOT DROPPABLE, the value
displayed is Not Nullable Not Droppable. Otherwise, the field is blank.

• Default: — A constant selected by default if no value was specified for this column.

• Heading: — The string displayed at the top of the column values when a select statement
is executed on the table.

Viewing table primary key properties
To view the primary key properties:
1. In the navigation tree, select the table.
2. In the right pane, click Primary Key.

The following details appear:

• Constraint Name: — The name of the constraint when the table was created. For more
information, see the HP NonStop SQL/MX Release 3.2 Reference Manual.

• Metadata UID: — The internal UID number for the constraint.

• Droppable: — This property indicates whether this constraint can be dropped. You can
specify whether the constraint can be dropped while creating the table.

• Position: — The position of the column in the primary key order.

• Column Name: — The name of the column (string).

• Data Type: — The SQL data type of the column.

• Sort Order: — The order specified as Ascending or Descending.

• Added By: — This property indicates whether the column was added by the system or
by the user.

Viewing hash key properties
To view the hash key properties:
1. In the navigation tree, select the table.
2. In the right pane, click Hash Key.

The following details appear:

• Key sequence: — The position of the column in the hash key order.

• Column Name: — The name of the column (string).

• Sort Order: — The order specified as Ascending or Descending.

Viewing store order properties
You can specify the store order properties while creating a table. Alternatively, the store order
properties can be determined by the system. For more information, see the HP NonStop SQL/MX
Release 3.2 Reference Manual. To view the store order properties:
1. In the navigation tree, select the table.
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2. In the right pane, click Store Order.
The following details appear:

• Position: — The position of the column in the key, for the physical file.

• Column Name: — The name of the column (string)

• Sort Order: — The order specified as Ascending or Descending.

• Added by: — The property indicates whether the column was added by the system or by
the user.

Viewing check constraints
To view the check constraints for a table:
1. In the navigation tree, select the table.
2. In the right pane, click Check Constraints.

The following details appear:

• Constraint Name: — The name of the check constraint.

• Metadata UID: — The internal UID number for the constraint.

• Text: — A string that defines the constraint, as shown in the SHOW DDL output.

Viewing unique constraints
To view the unique constraints for a table:
1. In the navigation tree, select the table.
2. In the right pane, click Unique Constraints.

The following details appear:

• Constraint Name: — The name of the unique constraint.

• Metadata UID: — The internal UID number for the constraint.

• Columns: — The names of the columns that are constrained.

Viewing foreign key properties
To view the foreign key properties:
1. In the navigation tree, select the table.
2. In the right pane, click Foreign Key.

The following details appear:

• Name: — The name of the foreign key constraint.

• Metadata UID: — The internal UID number of the foreign key.

• Foreign Table: — The name of the foreign table.

• Local Column: — The name of the local column of the foreign key.

• Foreign Column: — The name of the foreign column of the foreign key.

• Enforced: — The property indicates whether the referential integrity is enforced.

Viewing table attributes
To view the table attributes:
1. In the navigation tree, select the table.
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2. In the right pane, click Attributes.
The following details appear:

• Name — The name of the table.

• Metadata UID — The internal UID number of the table.

• Log Inserts Only: — A string value of True or False.

• Reorganize Enabled: — A string value of True or False.

• Update Statistics Enabled: — A string value of True or False.

• Last Updated Statistics: — A string value of Never or a timestamp in the yyyy-MM-dd
HH:mm:ss.FFFFFF format.

• Audit Compressed: — The property indicates whether the compressed audit-checkpoint
messages are generated for Disk Process 2 (DP2) files. It is expressed as True or False.

• Clear On Purge: — The property indicates the disk erasure when the file is dropped. It is
expressed as True or False.

• Block Size: — The length of a block.

• Maximum Size: — The maximum size, expressed in megabytes, to which a table can
grow. If the maximum size is 0, then the string Determined by system appears.

• Record Size: — The row size, expressed in bytes, in each logical record.

• Creation Time: — The time and date when a table was created. The time and date are
expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Redefinition Time: — The time and date when a table was last redefined. The time and
date are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

Viewing table partition properties
To view the partition properties:
1. In the navigation tree, select the table.
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2. In the right pane, click Partitions.
The following details appear:

• Partition Number: — The index number of the partition.

• System: — The name of the NonStop system where this partition is located.

• Name: — The partition name that is created by the system.

• File: — The physical file where the partition is located.

• Percent allocated: — The percentage of the partition used.

• Row count: — The number of rows in the partition.

• Rows Inserted Since Last Update Stats: — The number of rows inserted after the Update
Statistics command was last run.

• Rows Deleted Since Last Update Stats: — The number of rows deleted after the Update
Statistics command was last run.

• Rows Updated Since Last Update Stats: — The number of rows updated after the Update
Statistics command was last run.

• Primary Extents: — The size of primary extent in pages.

• Secondary Extents: — The size of secondary extents in pages.

• Max Extents: — The maximum number of extents.

• Allocated Extents: — The number of extents allocated.

• Max Size: — The maximum size of the partition.

• Current EOF: — The space used in the partition.

Viewing information on related objects
To view information on related objects:
1. In the navigation tree, select the table.
2. In the right pane, click Related Objects.

The following details appear:

• Relationship: — This property specifies the relationship of the table with the object. The
available values for this field are Uses, Used By, and Has.

• Related Object Type: — This property specifies the type of the related object. The available
values are Table and View.

• Related Object Name: — This property specifies the three-part ANSI object name. The
object name is hyperlinked to the related object.

• Metadata UID: — The internal UID number of the related object.

• Creation Time: — The time and date when the related object was created. The time and
date are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Redefinition Time: — The time and date when the related object was last redefined. The
time and date are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

Viewing DDL information of a table
To view DDL information related to the table:
1. In the navigation tree, select the table.
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2. In the right pane, click DDL.
The DDL tab displays the SHOW DDL output for the table. You can use this statement in MXCI
to create the table. For more information on the SHOW DDL command, see the HP NonStop
SQL/MX Release 3.2 Reference Manual.

Viewing information related to table statistics
To view information related to table statistics:
1. In the navigation tree, select the table.
2. In the right pane, click Statistics.

The histogram statistics for the table appear. For more information on viewing table statistics,
see “Viewing table statistics and their properties” (page 72).

Viewing information related to table privileges
To view information related to the table privileges:
1. In the navigation tree, select the table.
2. In the right pane, click Privileges.

The following details related to the table privileges appear:

• Grantee: — The name of the user whose privilege is described.

• Grantor: — The name of the user who granted the privileges or the special SQL user
names PUBLIC and SYSTEM.

• With Grant: — The property indicates whether the user has grant privileges.

• Grant Level: — The level at which the permissions are visible. The column displays
schema, object, and column values.

◦ Schema: — Indicates that permissions have been applied to the schema.

◦ Object: — Indicates that permissions were applied directly to the object whose
permissions are being displayed.

◦ Column: — Indicates that permissions are applied to the column. When an object-level
privilege applies to all columns, the individual column privileges do not appear.
Otherwise, the individual column permissions appear.

• Privileges: — Describes the privilege of the user. The value is a list of granted privileges
that are separated by a comma. DDL and DML privileges are grouped accordingly. For
the list of privileges, see the HP NonStop SQL/MX Release 3.2 Reference Manual.

Displaying table indexes and their properties
To view the table indexes:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Database.

MXDM displays a list of existing systems.
3. In the navigation tree, expand the contents of the system.

The list of catalogs appears.
4. Expand the contents of a catalog.

The list of schemas appears.
5. Expand the contents of a schema.

The Tables folder appears.
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6. Expand the contents of a table.
The Indexes and Triggers folders appear.

7. Within the Indexes folder, select the required Index.
In the right pane, the following tabs related to the Index appear:

• Columns

• Attributes

• DDL

• Partitions
Figure 20 (page 59) shows the table index properties.

Figure 20 Table index properties

Viewing the table index columns
To view the table index columns:
1. In the navigation tree, select the index.
2. In the right pane, click Columns.

The following attributes and their values appear:

• Column Name: — The name of the column (string).

• Sort Order: — This attribute specifies the sort order as Ascending or Descending.

• Added By: — This attribute ndicates whether the column was added by the system or a
user.

Viewing the table index attributes
To view the table index attributes:
1. In the navigation tree, select the index.
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2. In the right pane, click Attributes.
The following attributes and their values appear:

• Name: — The name of the index.

• Metadata UID: — The internal UID number of the index.

• Unique: — This attribute specifies whether the index is unique. The available values are
Yes or No.

• Populated: — This attribute specifies whether the index is populated. The available values
are Yes or No.

• System Created: — This attribute indicates whether the index was created by the system.
The available values are Yes or No.

• Hash Partitioned: — This attribute indicates whether the index is partitioned by a hashing
key. The available values are Yes or No.

• Audit Compressed: — This attribute indicates whether compressed audit-checkpoint
messages are generated for Disk Process 2 (DP2) files. The available values are ON or
OFF.

• Block Size: — The length of a block in bytes.

• Clear On Purge: — This attribute indicates whether the disk the erased when the index
is dropped. The available values are ON or OFF.

• Creation Time: — The time and date when the index was created. The time and date are
expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Redefinition Time: — The time and date when the index was last redefined. The time and
date are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

Viewing the DDL output for a table index
To view the DDL output for a table index:
1. In the navigation tree, select the index.
2. In the right pane, click DDL.

The DDL tab displays the SHOW DDL output for the index. For more information on the SHOW
DDL command, see the HP NonStop SQL/MX Release 3.2 Reference Manual.

Viewing information related to table index partitions
To view information related to table index partitions:
1. In the navigation tree, select the index.
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2. In the right pane, click Partitions.
The following details related to table index partitions appear:

• Partition Number: — The name of the column (string).

• System: — This attribute specifies the sort order as Ascending or Descending.

• Name: — This attribute specifies whether the column was added by the system or a user.

• File: — The physical file where the partition is located.

• Percent allocated: — The percentage of the partition used.

• Row count: — The number of rows in the partition.

• Rows Inserted Since Last Update Stats: — The number of rows inserted after the Update
Statistics command was last run.

• Rows Deleted Since Last Update Stats: — The number of rows deleted after the Update
Statistics command was last run.

• Rows Updated Since Last Update Stats: — The number of rows updated after the Update
Statistics command was last run.

• Primary Extents: — The size of the primary extent in pages.

• Secondary Extents: — The size of the secondary extents in pages.

• Max Extents: — The maximum number of extents.

• Allocated Extents: — The number of extents allocated.

• Max Size: — The maximum size of the partition.

• Current EOF: — The space used in the partition.

Displaying table triggers and their properties
A trigger is a mechanism that resides in the database and specifies that when a particular action—an
insert, delete, or update occurs on a table, SQL/MX should automatically perform one or more
additional actions.
To view the table triggers:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Database.

MXDM displays a list of existing systems.
3. In the navigation tree, expand the contents of the system .

The list of catalogs appears.
4. Expand the contents of a catalog.

The list of schemas appears.
5. Expand the contents of a schema.

The Tables folder appears.
6. Expand the contents of a table.

The Indexes and Triggers folders appear.
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7. Within the Triggers folder, select the required Trigger.
In the right pane, the following tabs related to the trigger appear:

• Attributes

• Related Objects

• DDL
Figure 21 (page 62) shows the table trigger properties.

Figure 21 Table trigger properties

Viewing the table trigger attributes
To view the table trigger attributes:
1. In the navigation tree, select the trigger.
2. In the right pane, click Attributes.

The following attributes and their values appear:

• Name: — The name of the trigger.

• Metadata UID: — A unique ID of the trigger.

• Is Enabled: — The attribute specifies whether the trigger is enabled. The available values
are Yes and No.

• Activation Time: — The attribute specifies when the trigger is activated. This value is used
in combination with an operation. The available values are Before and After.

• Operation: — The attribute specifies the operation that causes the trigger to be activated.
The available values are Insert, Delete, and Update.

• Granularity: — The attribute specifies Row or Statement trigger. Row triggers are allowed
for all Time and Event combinations. Statement triggers are allowed for AFTER events.
For more information, see the HP NonStop SQL/MX Release 3.2 Reference Manual.

• Creation Time: — The time and date when the trigger was created. The time and date
are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Redefinition Time: — The time and date when the trigger was last redefined. The time
and date are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

Viewing information on related objects
To view information on related objects:
1. In the navigation tree, select the trigger.

62 Viewing database objects



2. In the right pane, click Related Objects.
The following details appear:

• Relationship: — This attribute specifies the relationship between this trigger and the object.

• Related Object Type: — This attribute specifies the type of the object.

• Related Object Name: — This attribute specifies the name of the object. The object name
is linked to the object.

• Metadata UID: — A unique ID of the related object. This ID is a long value.

• Creation Time: — The time and date when the related object was created. The time and
date are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Redefinition Time: — The time and date when the related object was last redefined. The
time and date are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Operation: — This attribute specifies the types of operations that are performed on this
object to activate the trigger. The value is one of the following:

◦ Delete

◦ Insert

◦ Select

◦ Update

◦ Call

• Is Subject Table: — This attribute specifies whether the target is a subject table. The
available values are True and False.

Viewing the DDL output for a table trigger
To view the DDL output for a table trigger:
1. In the navigation tree, select the trigger.
2. In the right pane, click DDL.

In the right pane, the DDL tab displays the DDL output for the SHOW DDL command. You can
highlight and copy contents. However, you cannot edit the contents. For more information on
the SHOW DDL command, see the HP NonStop SQL/MX Release 3.2 Reference Manual.

Managing objects using the SHOW DDL option
The SHOW DDL option enables you to view the DDL statements of multiple objects in a schema.
To use the SHOW DDL option for an object, right-click any object within the Schemas folder in the
navigation tree, and select SHOW DDL....
Figure 22 (page 64) shows the SHOW DDL... dialog.
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Figure 22 SHOW DDL dialog

NOTE: The SHOW DDL option is available only for a schema node and its child nodes in the
navigation tree. The SHOW DDL option is not available for catalogs and the Schemas folder.

In the SHOW DDL... dialog, the Select Objects pane displays the list of systems and the objects that
they contain. You can select these objects.
If you select the SHOW DDL option on a folder node in the main navigation tree, the Select Objects
pane displays the navigation tree with the corresponding folder node and all its child nodes
selected. If you invoke the SHOW DDL option on a leaf node in the main navigation tree, the Select
Objects pane displays the navigation tree with the corresponding leaf node selected.
You can select objects from only one schema. If you select objects from different schemas, an error
message appears.
Table 19 (page 64) describes the options in the SHOW DDL... dialog.

Table 19 SHOW DDL options

DescriptionOption

Loads the SHOW DDL output of the selected objects and replaces the contents in the DDL
Output pane.

Load

Appends the selected objects to the existing contents in the DDL Output pane.Append

Clears the check boxes against the selected objects in the Selected Objects pane.Clear All

Clears the DDL Output field.Clear

Saves the contents of the DDL Output field using the File menu dialog.Save

Closes the SHOW DDL... dialog.Close

Viewing schema views and their properties
To view the schema views and their properties:
1. Log on to the HP NonStop SQL/MX Database Manager.
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2. Under the navigation tree pane, click Database.
MXDM displays a list of existing systems.

3. In the navigation tree, expand the contents of the system.
The list of catalogs appears.

4. Expand the contents of a catalog.
The list of schemas appears.

5. Expand the contents of a schema.
The Views folder appears.

6. Select a view.
In the right pane, the following tabs related to the view appear:

• Columns

• Attributes

• Related Objects

• DDL

• Privileges
Figure 23 (page 65) shows the View properties

Figure 23 View properties

Viewing properties related to view columns
To view the properties related to view columns:
1. In the navigation tree, select the view.
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2. In the right pane, click Columns.
The following details related to view columns appear:

• Column Name — The name of the column (string).

• Source Object — The name of the source object associated with the column. If it is a
computed object, this field is blank. Clicking the source object name directs you to the
location of the object.

• Data Type: — The SQL data type of the column.

• Nullable: — If a column is NOT NULL or NOT NULLABLE NOT DROPPABLE, the value
displayed is Not Nullable Not Droppable. Otherwise, the field is blank.

• Default: — The default value of the column.

• Heading: — The string to be used as the column heading when a SELECT statement in
MXCI is used to display the column.

Viewing attributes of a view
To view the attributes of a view:
1. In the navigation tree, select the view.
2. In the right pane, click Attributes.

The following details related to view attributes appear:

• Name — The name of the view.

• Metadata UID — Internal UID number of the view.

Viewing information on related objects
To view information on related objects:
1. In the navigation tree, select the view.
2. In the right pane, click Related Objects.

The following details appear:

• Relationship: — The attribute specifies the relationship of the view with the object specified.
The available values for this field are Uses, Used By, and Has.

• Related Object Type: — This attribute specifies the type of the related object. The available
values are Table and View.

• Related Object Name: — This attribute specifies the three-part ANSI object name. The
object name is linked to the related object.

• Metadata UID: — The unique ID of the view.

• Creation Time: — The time and date when the related object was created. The time and
date are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Redefinition Time: — The time and date when the related object was last redefined. The
time and date are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

Viewing DDL information of a table
To view DDL output for a view:
1. In the navigation tree, select the view.
2. In the right pane, click DDL.

In the right pane, the SQL statement used to create the view appears.

66 Viewing database objects



Viewing information related to view privileges
To view information related to the view privileges:
1. In the navigation tree, select the view.
2. In the right pane, click Privileges.

The following details related to the view privileges appear:

• Grantee: — The name of the user whose privilege is described.

• Grantor: — The name of the user who granted the privileges or the special SQL user
names PUBLIC and SYSTEM.

• With Grant: — This attribute indicates whether the user has grant privileges.

• Grant Level: — The level at which the permissions are visible. The values displayed in
this column are schema, object, and column.

◦ Schema: — This attribute indicates that permissions have been applied to the schema.

◦ Object: — This attribute indicates that permissions were applied directly to the object
whose permissions are displayed.

◦ Column: — This attribute indicates that permissions are applied to the column. When
an object-level privilege applies to all columns, the individual column privileges do
not appear. Otherwise, the individual column permissions appear.

• Privileges: — This attribute describes the privilege of the user. The value is a list of granted
privileges that are separated by a comma. DDL and DML privileges are grouped
accordingly. For the list of privileges, see the HP NonStop SQL/MX Release 3.2 Reference
Manual.

Viewing procedures and their properties
To view the schema procedures and their properties:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Database.

MXDM displays a list of existing systems.
3. In the navigation tree, expand the contents of the system.

The list of catalogs appears.
4. Expand the contents of a catalog.

The list of schemas appears.
5. Expand the contents of a schema.

The Procedures folder appears.
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6. Select a procedure.
In the right pane, the following tabs related to the procedure appear:

• Attributes

• Parameters

• Related Objects

• DDL

• Privileges
Figure 24 (page 68) shows the properties of a procedure.

Figure 24 Procedure properties

Viewing attributes of a procedure
To view the attributes of a procedure:
1. In the navigation tree, select the procedure.
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2. In the right pane, click Attributes.
The following details related to attributes appear:

• Name — The name of the procedure.

• Metadata UID — The unique ID number of the procedure.

• Dynamic Result Sets: — The maximum number of result sets returned.

• SQL Access: — This attribute specifies how the procedure accesses the SQL data. If the
procedure does not perform SQL operations, the value displayed in this field is N.
Otherwise, the value displayed in this field is one of the following:

◦ CONTAINS SQL

◦ MODIFIES SQL DATA

◦ READS SQL DATA

• Parameters: — The parameter type. For information on data types, see the HP NonStop
SQL/MX Guide to Stored Procedures in Java.

• External Path: — Either an OSS directory or a JAR file path that contains the SPJ class
file.

• External File: — The name of Java class file that contains the procedure code.

• External Name: — This attribute specifies the case-sensitive name of the SPJ method. For
more information, see the HP NonStop SQL/MX Release 3.2 Reference Manual.

• Language: — The programming language in which the procedure code is written.

• Parameter Style: — The programming language associated with the format of the
procedure parameters.

• Deterministic: — If in the Create Procedure statement you specified the option
DETERMINISTIC, this column contains Yes. If you specified NOT DETERMINISTIC,
this column contains a No. This value specifies whether the SPJ always returns the same
values for OUT and INOUT parameters for a given set of argument values
(DETERMINISTIC) or does not return the same values (NOT DETERMINISTIC, which
is the default option). SQL/MX allows both options but always treats the SPJ as
nondeterministic.

• Isolate: — This attribute specifies that the SPJ executes either in the environment of the
database server (NO ISOLATE) or in an isolated environment (ISOLATE, which is the
default option). SQL/MX allows both options but always executes the SPJ in the SQL/MX
user-defined routine (UDR) server process (ISOLATE).

• Transaction Attributes: — This attribute indicates whether a transaction is required.

• Creation Time: — The time and date when the procedure was created. The time and date
are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Redefinition Time: — The time and date when the procedure was last redefined. The time
and date are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

Viewing parameters of a procedure
To view the parameters of a procedure:
1. In the navigation tree, select the procedure.
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2. In the right pane, click Parameters.
The following details related to parameters appear:

• Name — The name of the parameter.

• Direction — The following values appear:

◦ IN — Passes data to the procedure.

◦ OUT — Accepts data from the procedure. This value is the default for array
parameters.

◦ INOUT — Passes data to and accepts data from the procedure.

• SQL Data Type: — This attribute specifies an SQL data type that corresponds to the Java
parameter of the procedure's Java method. For information on SQL data types, see the
HP NonStop SQL/MX Release 3.2 Reference Manual.

• Java Data Type: — This attribute specifies a Java data type that can be mapped. For
information on Java data types, see the HP NonStop SQL/MX Guide to Stored Procedures
in Java.

Viewing information on related objects
To view information on related objects:
1. In the navigation tree, select the view.
2. In the right pane, click Related Objects.

The following details appear:

• Relationship: — This attribute specifies the relationship of the procedure with the object
specified. The available value for this field is References, Used By, and Has.

• Related Object Type: — This attribute specifies the type of the object that the procedure
references. The available values are Table and View.

• Related Object Name: — This attribute specifies the three-part ANSI object name. The
object name is linked to the object.

• Metadata UID: — A unique ID of the related object.

• Creation Time: — The time and date when the related object was created. The time and
date are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

• Redefinition Time: — The time and date when the related object was last redefined. The
time and date are expressed in the yyyy-MM-dd HH:mm:ss.FFFFFF format.

Viewing DDL information of a procedure
To view DDL information related to the table:
1. In the navigation tree, select the procedure.
2. In the right pane, click DDL.

The DDL tab displays the SHOW DDL output for the procedure. For more information on the
SHOW DDL command, see the HP NonStop SQL/MX Release 3.2 Reference Manual.

Viewing information related to procedure privileges
To view information related to the procedure privileges:
1. In the navigation tree, select the procedure.
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2. In the right pane, click Privileges.
The following details related to the procedure privileges appear:

• Grantee: — The name of the user whose privilege is described.

• Grantor: — The name of the user who granted the privileges and the special SQL user
names PUBLIC and SYSTEM.

• With Grant: — This attribute indicates whether the user has grant privileges.

• Grant Level: — The level at which the permissions are visible. The column displays the
schema, object, and column values.

◦ Schema: — This attribute indicates that permissions are applied to the schema.

◦ Object: — This attribute indicates that permissions were applied directly to the object
whose permissions are displayed.

◦ Column: — This attribute indicates that permissions are applied to the column. When
an object-level privilege applies to all columns, the individual column privileges do
not appear. Otherwise, the individual column permissions appear.

• Privileges: — This attribute describes the privilege of the user. The value is Execute.
DDL and DML privileges are grouped accordingly. For the list of privileges, see the HP
NonStop SQL/MX Release 3.2 Reference Manual.

Viewing SQL/MP aliases and their properties
To view the SQL/MP aliases and their properties:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Database.

MXDM displays a list of existing systems.
3. In the navigation tree, expand the contents of the system.

The list of catalogs appears.
4. Expand the contents of a catalog.

The list of schemas appears.
5. Expand the contents of a schema.

The SQL/MP Aliases folder appears.
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6. Select an SQL/MP alias.
In the right pane, the following tabs related to the procedure appear:

• Attributes

• DDL
Figure 25 (page 72) shows the properties of an SQL/MP alias.

Figure 25 SQL/MP alias properties

Viewing attributes of the SQL/MP alias
To view the attributes of a SQL/MP alias:
1. In the navigation tree, select the SQL/MP alias.
2. In the right pane, click Attributes.

The following details related to attributes appear:

• Name — The name of the SQL/MP alias.

• Metadata UID — A unique ID number of the SQL/MP alias.

• SQL/MP table: — The Guardian location of the SQL/MP table associated with the alias.

Viewing DDL information of a SQL/MP alias
To view DDL information related to the SQL/MP alias:
1. In the navigation tree, select the SQL/MP alias.
2. In the right pane, click DDL.

The DDL tab displays a statement that you can use to create the SQL/MP Alias.

Viewing table statistics and their properties
MXDM enables you to view table statistics. You can use the table statistics to troubleshoot and to
create additional indexes. To view table statistics, the default catalog (NONSTOP_SYSTEM_NSK)
and the default schema (PUBLIC_ACCESS_SCHEMA) are required. If the default catalog and
schema are not available, table statistics are not displayed. For information on creating the default
catalog and schema, see the HP NonStop SQL/MX Connectivity Service Manual for SQL/MX
Release 3.2.
To view information related to table statistics:
1. Log on to the HP NonStop SQL/MX Database Manager.
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2. Under the navigation tree pane, click Database.
MXDM displays a list of existing systems.

3. In the navigation tree, expand the contents of the system.
The list of catalogs appears.

4. Expand the contents of a catalog.
The list of schemas appears.

5. Expand the contents of a schema.
The Tables folder appears.

6. Select a table.
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7. In the right pane, click Statistics.
The following histogram statistics for the table appear:

• Column Name: — The name of the column.

• Data Type: — This attribute specifies the column data type.

• # Nulls: — The number of null values for the column.

• Min Value: — The minimum value of the column.

• Max Value: — The maximum value of the column.

• Skew: — The CV entry in histograms table for the column.

• UEC: — The TOTAL_ UEC (Unique Entry Count) entry from histograms table for the
column.

• Cardinality: — The ROWCOUNT entry from histograms table for the column.

• Last Stats Timestamp: — The STATS_TIME from histogram table for the column.

NOTE: The Statistics tab includes information only if the table statistics are stored. To store
the table statistics, you must execute the Update Statistics statement on the table.

Figure 26 (page 74) shows the table statistics.

Figure 26 Table statistics

For more information on the HISTOGRAMS table, see the HP NonStop SQL/MX Release 3.2
Reference Manual.
To display a sample view of the table column statistics, click the column name, double-click any
row in the right pane, or click View Sampled Column Statistics located at the top right pane.
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The top pane displays the column name, table name, the percentage sampled, and the time when
the sample was taken.
The following details appear:

• Data Type: — Displays the column data type.

• # Nulls: — The number of null values for the column.

• Skew: — The CV entry from histograms table for this column.
The middle pane displays the ten most frequent values for the column. The value itself and its
cardinality (number of occurrences) appear.
The bottom pane displays the following histogram intervals for the column data boundaries:

• Interval Number: — The INTERVAL_NUMBER entry from the HISTOGRAM_INTERVALS table.

• Min Boundary: — The minimum value for the interval, for the column.

• Max Boundary: — The maximum value for the interval, for the column.

• Stats UEC: — The total UEC entry from the HISTOGRAMS table for the column.

• Sampled UEC: — The INTERVAL_UEC from the HISTOGRAM_INTERVALS table.

• Stats Cardinality: — The STATS_TIME from the HISTOGRAMS table for the column.

• Sampled Cardinality: — The sampled_UEC from the HISTOGRAMS table for this column.
The diagram at the bottom right relates the Sampled Cardinality to the Interval Number from the
Intervals table located at the left of the diagram.
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7 Managing MXCS objects
This chapter discusses the following topics:

• “Viewing MXCS servers” (page 76)

• “Stopping an MXCS server” (page 78)

• “Viewing MXCS Services” (page 78)

• “Starting up an MXCS service” (page 79)

• “Stopping an MXCS service” (page 80)

• “Viewing data sources” (page 81)

• “Creating a data source” (page 82)

• “Copying a data source” (page 89)

• “Starting up a data source” (page 90)

• “Stopping a data source” (page 90)

• “Updating a data source” (page 91)

• “Deleting a data source” (page 91)

• “Starting and stopping server traces” (page 91)

• “Viewing MXCS user permissions” (page 92)

• “Adding an MXCS user” (page 93)

• “Editing MXCS user permissions” (page 94)

• “Deleting an MXCS user” (page 94)

NOTE:
• Any user can view information related to MXCS objects. However, only users with OPERATOR

permission can perform management tasks, such as starting and stopping MXCS services and
MXCS servers.

• All users can view all data sources. Only MXCS users with OPERATOR permission can perform
management tasks on a data source.

Viewing MXCS servers
To view all MXCS servers for a system:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.

MXDM displays a list of existing systems.
3. Expand a system, and click MXCS Services.
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4. In the right pane, click MXCS Server Status.
The list of MXCS servers and their status appear.
Figure 27 (page 77) shows the MXCS servers and their status.

Figure 27 MXCS Servers Status

Table 20 (page 77) describes the fields in the MXCS Server Status tab.

Table 20 MXCS Server Status fields

DescriptionField

The operating system process name of the server.Process Name

The MXCS service to which the process belongs.Service Name

The user-defined name of the data source. A data source is a data structure that
contains connection information such as CQDs, SETS, and Controls. The
ODBC/MX driver uses this information to connect to the database.

Data Source Name

The current state of the server, such as Available and Connected.State

The process ID of the client connected to the server. If there is no connection, the
value is set to 0.

PID Client

The name of the client application connected to the server. If there is no
connection, the field is blank.

Application Name

The name of the user connected to the server. If there is no connection, the field
is blank.

User Name

The system name where the client application is running. If there is no connection,
the field is blank.

Computer Name

CPU number where the server is running.CPU

The operating system process ID assigned to the server.Server PIN

The port number and object reference information for the service.Port

The date and time of the last update to the server's state.Last Updated Time

Term
MXCS server
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Stopping an MXCS server
To stop an MXCS server:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.
3. Expand the system that contains the MXCS servers that you want to stop.
4. Click MXCS Services.
5. In the right pane, click MXCS Server Status to display the list of MXCS servers.
6. Select the server that you want to stop. You can select more than one server.
7. Click Stop...

The Stopping Server dialog appears.
8. Click Stop Immediately.

The MXCS server stops.

CAUTION: Stop Immediately stops the server without waiting to finish any current database
statements or server processes. The transaction manager rolls back all uncommitted transactions
held by these MXCS servers. All client connections are closed.

NOTE: After you click a stop option, you cannot cancel the operation.

Terms
operator permission
MXCS server

Viewing MXCS Services
Any user can view MXCS services. To view all MXCS services for a system:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.
3. In the navigation tree pane, expand the system that contains the MXCS services.
4. Click MXCS Services.
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5. In the right pane, click MXCS Services to display details of the Association and Configuration
servers.
Figure 28 (page 79) show the properties related to MXCS Services.

Figure 28 MXCS Services tab

Table 21 (page 79) describes the fields in the MXCS Services tab.

Table 21 MXCS Services fields

DescriptionField

The MXCS service to which the process belongs.Service Name

Association server or Configuration server.
Association Servers (MXOAS) are persistent processes. MXOAS provides
database connectivity to client applications. They spawn MXCS server
processes, which handle database requests from clients. MXCS server
processes execute the database queries for the clients. They can spawn
Executor Server Processes (ESPs) to achieve parallelism in the execution
of queries. Configuration Servers (MXOCFG) manage the MXCS
configuration data. For more information on MXOAS, see HP NonStop
ODBC/MX Driver for Windows for SQL/MX Release 3.2.

Service Type

The operating system process name of the server.Process Name

The current state of the service.State

CPU number where the server is running.CPU

The operating system process ID assigned to the component.Server PIN

The port number and object reference information for the service.Port

The date and time of the last update of the service state.Last Updated Time

Starting up an MXCS service
Starting up an MXCS service changes the state of the service from Stopped to Available.
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To start up an MXCS service:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.
3. In the navigation tree pane, select the system that contains the MXCS services.
4. In the navigation tree pane, expand the MXCS Services folder for the system.
5. Right-click the name of the service that you want to start up, and select Start.

The MXCS service starts.

This action enables the MXCS service and the following components:
• Association server

• Configuration server

• Data sources configured with the automatic startup option
If the MXCS service state does not change to the Available state, contact HP support.
Related Topic
Terms
operator permission
Association server
Configuration server
Data sources
MXCS service

Stopping an MXCS service
When you stop an MXCS service, the configuration server remains Available, but the association
server changes from the Available state to the Stopped state. This operation effectively stops any
data source that is currently started.
To stop an MXCS service:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.
3. In the navigation tree pane, select the system that contains the MXCS services.
4. In the navigation tree pane, expand the MXCS Services folder for the system.
5. Right-click the name of the service that you want to stop, and select Stop...

The Stopping Service dialog appears.
6. Enter a reason for stopping the service.
7. Click one of the following options:

NOTE: After you click a stop option, you cannot cancel the operation.

• Stop on Client Disconnect

• Stop Immediately

CAUTION: Stop Immediately disables the MXCS service without waiting for the MXCS
servers to finish current operations. The transaction manager rolls back all uncommitted
transactions held by these MXCS servers. All client connections are closed.

The MXCS service stops.

Terms
operator permission
association server
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Viewing data sources
To view data sources:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.

MXDM displays a list of existing systems.
3. Expand the system and click the Data Sources folder.

Figure 29 (page 81) shows the data sources in the navigation tree. The right pane displays
the details corresponding to the data sources.

Figure 29 Data sources

The Data Sources tab displays the following data source properties:
• Data Source Name — The name of the data source.

• Maximum — The upper limit of the servers that can be operational for the service on this
data source.

• Idle — The lower limit of the available idle servers that are operational for the service on
this data source. This value represents idle servers that are waiting for user connections.

• Initial — The suggested number of servers that each service starts when the data source
is first started.
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4. In the navigation tree pane, click a data source. In the right pane, the properties in the Data
Source Status tab appear.
Figure 30 (page 82) shows the properties in the Data Source Status tab.

Figure 30 Properties in the Data Source Status tab

In the right pane, the following details related to the data source appear:

• Data Source Name — The name of the data source.

• Service Name — The MXCS service to which the process belongs.

• State — The current state of the data source.

• Tracing — The current state of server tracing.

• Total — The total number of servers running.

• Connected — The number of servers connected to clients.

• Maximum — The upper limit of the servers that can be operational for the service on this
data source.

• Idle — The lower limit of the available idle servers that are operational for the service on
this data source. This value represents idle servers that are waiting for user connections.

• Initial — The number of servers that each service starts when the data source is first started.

• Last State Changed — The date and time when the data source state was last updated.

Term
data source

Creating a data source
To create a data source:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.

MXDM displays a list of existing systems.
3. Expand the system for which you want to create a new data source.
4. Right-click Data Sources, and select Create Data Source...

The Create Data Source window appears.
5. Configure the data source properties, as described in:

• “Using General Properties” (page 83).

• “Using the DEFINEs and SETs tab” (page 85)
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• “Using the Control Query Defaults tab” (page 87)

• “Using the Control Table Statements tab” (page 87)

NOTE:
Some tabs provide tooltips that explain the use of an option or the range of values supported
for a field. Figure 31 (page 83) shows a tool tip for one of the fields.

Figure 31 Tooltip in tabs

6. After configuring the data source properties, click Create.
7. Refresh the navigation tree pane.

The new data source appears.
8. To start up the data source, see “Starting up a data source” (page 90).
Terms
data source
navigation tree pane

Using General Properties
Table 22 (page 83) describes the properties displayed in the General Properties tab.

Table 22 General Properties options

DescriptionOptionGroup

You must assign a unique name for the new data source. The name can
be a maximum of 128 characters (any characters) without leading or

NameData Source Name

trailing spaces. Leading or trailing spaces are automatically removed
before the name is sent to the server. Embedded spaces are not removed,
and will return an error.

Specifies that MXCS automatically starts up the initial MXCS servers for
the data source when the MXCS service is started.

AutomaticStart Mode

You must manually start up the MXCS servers for the data source when
the MXCS service is in the Started state. This value is the default.

Manual

Specifies the number of minutes that an MXCS server remains idle before
it stops. This timeout occurs only under the following conditions:

Server Idle TimeoutPerformance

• The idle server is not connected to a client.

• The number of servers exceeds the number of idle servers configured
for the data source.

The system default is 600 seconds. You can assign a value between 1
and 2,147,483,647.
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Table 22 General Properties options (continued)

DescriptionOptionGroup

Specifies the number of minutes that a client-server connection remains
idle before the MXCS server terminates the connection.

Connection Idle
Timeout

You must assign a value between 1 and 2,147,483,647. The system
default is 600 seconds.

You must select this option to collect statistics about the connection and
the session. Data source statistics are stored in the Event Monitoring Service
(EMS) log. The event ID is 21035.

Connection
Information

Session Statistics

You must select this option to collect statistics about individual SQL
statements. Data source statistics are stored in the EMS log. The event ID
is 21035.

Session Summary

Specifies the upper limit of the servers that can be operational for a service
on the data source.

MaximumNumber of Servers

The default is 1. The range is 0 to 32767.
0 specifies the system default that is determined by the system at run time.
If you use the default of 1000 ports for MXCS during installation, the range
is 1 through 997.
If you configure more than 1000 ports for MXCS, the value for Maximum
is the number of configured ports minus 3. In this case, the actual maximum
number of MXCS servers can sometimes be greater than the number of
ports configured.

Specifies the lower limit of the available idle MXCS servers that are
operational for a service on the data source.

Idle

The values range from 0 to 32767. The default is 0.
This value cannot exceed the maximum server value.

CAUTION: The sum of all the Idle values for a given system must not
exceed the number of ports specified when the MXCS service was started
up. HP recommends that this sum not exceed 200.

Specifies the suggested number of MXCS servers that each service starts
up when the data source is first started up.

Initial

The default is 0. The values range from 0 to 32767. This value cannot
exceed the maximum server value.

Specifies the priority assigned to a process started for this data source.
The values range from 1 to 199.

InitialProcess Priority

Specifies the priority of the MXOAS process when the servers are created.System Default

Specifies the processing nodes (CPUs) you want to use for this data source.CPU OrderCPU Utilization
Enter a list of CPU numbers, separated by commas. For example:
1,2,4,5,15.

Specifies that the SQL/MX software determines the CPU utilization
automatically.

System Default

Specifies the statistics about individual SQL statements.SQL StatementStatement Statistics

Specifies the statistics about SQLExecute.SQLExecute

Specifies the statistics about SQLPrepare.SQLPrepare

Specifies the statistics about SQLExecDirect.SQLExecDirect

Specifies the statistics about SQLFetch.SQLFetch

See “Adding and modifying the resource management policy” (page 85).AddResource
Management

84 Managing MXCS objects



Table 22 General Properties options (continued)

DescriptionOptionGroup

See “Adding and modifying the resource management policy” (page 85).Modify

Removes the selected resource management policy.Remove

Adding and modifying the resource management policy
The Resource Management field of the Create New Data Source dialog displays each resource
management policy that is currently in effect for a data source. You can add, modify, and remove
a resource management policy for the selected data source.

NOTE: You can enter only one resource management policy for each attribute name.

Table 23 (page 85) describes the fields in the Add and Modify dialogs.

Table 23 Fields in the Add and Modify dialogs

DescriptionField

The name of a resource management policy attribute that limits the execution of user queries from
a client application, based on cost.

Attributes:

The action to be taken by MXCS when the limit is exceeded. In all cases, an event message is sent
to the event log. Valid values are:

Action:

• LOG — The user query continues execution.

• LOG_WITH_INFO — The user query returns a warning message to the client; the query execution
continues.

• STOP — The user query returns an error message to the client; the query execution stops.

The maximum value for the attribute. This value is any positive number; the maximum is the value
of the LARGEINT SQL data type.

Limit:

Enter the details and click OK. The new resource management policy is added to the attribute list
or the currently configured policy is modified. These changes are effective when you subsequently
connect to a server in the data source.

Using the DEFINEs and SETs tab
This section describes the DEFINEs and SETs tabs.

About DEFINEs
A DEFINE statement is a named set of attribute-value pairs associated with a process. SQL/MX
allows DEFINEs to be used as logical names for tables, views, or partitions in statements that query
SQL/MP objects.
DEFINE statements are stored as part of the configuration data for the data source. They are
retrieved and set by the association server when it reads the startup values for the data source.
Changes become effective the next time a connection is made to a server in the data source.
Table 24 (page 85) describes the fields in the DEFINEs tab.

Table 24 DEFINEs tab buttons

FunctionButton

Displays the Add DEFINE dialog.Add...

Displays the Edit DEFINE dialog.Modify...

Removes the selected DEFINE statement.Remove
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Figure 32 Add DEFINE

About SETs
SET variables affect the behavior of MXCS. For example, you can set default catalog and schema
names for servers running in this data source when they are not set at the client data source. Client
data source values take precedence over server data source values.

NOTE: SET variables are primarily used by HP support.

SET variables are stored as part of the configuration data for the data source. They are retrieved
by the association server when it reads the startup values for the data source. The data source
server then sets the value when a connection is established.
Table 25 (page 86) describes the SET tab functions.

Table 25 Functions on the SETs Tab

FunctionButton

Displays the Add SET dialog.Add...

Displays the Edit SET dialog.Modify...

Removes the selected SET variable.Remove

Some SET commands require that you specify a value in single quotes. For example, SET SESSION
commands always require that the value be within single quotes. Figure 33 (page 86) shows an
example of the SET SESSION command.

Figure 33 SET SESSION example 1

Internally, MXDM concatenates the Name and Value fields to form the SET command. Therefore,
you can specify the value alone in the value field and the rest of the command in the Name field,
as shown in the example. Alternatively, you can specify the type of the SET command in the Name
field and the rest of the command in the Value field. HP recommends that you use this approach.
Figure 34 (page 87) shows an example.
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Figure 34 SET SESSION example 2

Using the Control Query Defaults tab
To add or modify a CQD configured for a data source:
1. Under the navigation tree pane, click Connectivity.
2. Complete the initial steps to create a data source until you see the following shown in

Figure 35 (page 87).

Figure 35 Data source configuration

For information on creating a data source, see “Creating a data source” (page 82) or
“Updating a data source” (page 91))

3. Click Control Query Defaults.
4. Click Add... or Modify...
5. In the CQD Name field, enter a new name or change the existing name.
6. In the Value field, enter a new CQD value, or change the current value.

Figure 36 Add CQD

Using the Control Table Statements tab
The Control Table Statements tab allows you to modify certain options for specific tables.
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Table 26 (page 88) describes the options.

Table 26 Options in the Control Table Statements tab

DescriptionValue

Specifies name of the table.Name

Determines the result if you attempt to access data with read committed or if you serialize access,
and the data is locked by another user.

If-Locked

Specifies whether to use Multi-dimensional Access Method (MDAM) for subsequently compiled DML
statements that access the index.

MDAM

Specifies the priority for subsequent file system requests to MDAM. MDAM uses the priority to ensure
efficient performance in a mixed workload environment.

Priority

Specifies whether to perform similarity checks for new and previous tables to avoid statement
recompilation. This option applies only to tables. It does not apply to views.

Similarity Check

Determines whether to use table locks for subsequently compiled DML statements that access the
table or view.

Table Lock

Specifies the amount of time allowed to complete file-system requests from the DML operations. If the
time elapses before the file system can grant a request to lock data, the DML statement fails and
SQL/MX returns an error.

Timeout

NOTE: This timeout applies to static operations only.

If-Locked

DescriptionValue

Specifies the value used is the system default setting that exists at the time of execution.<Not Set>

Returns the file-system error 73. For more information on file-system errors, see the HP NonStop SQL/MX
Release 3.2 Messages Manual.

Return

Indicates that SQL/MX waits for another user to release the lock, until the timeout period elapses.Wait

MDAM

DescriptionValue

The value used is the system default setting that exists at execution.<Not Set>

SQL/MX determines whether to use MDAM.Enable

MDAM is not used.Off

MDAM is used.On

Priority
The possible values are 1 through 9, where 9 is the highest value. You can specify a higher priority
for short-duration OLTP-type requests running with concurrent long-duration query requests.

CAUTION: Using the highest possible value (9) can interfere with SQL/MX system-level activity.
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Similarity check

DescriptionValue

The value used is the system default setting that exists at execution.<Not Set>

SQL/MX recompiles the statement at run time, depending on the outcome of late name resolution,
timestamp comparison, or table redefinition.

Off

SQL/MX performs similarity checks at run time to determine whether the new table is similar to the
previous table. If similar, SQL/MX uses the table without recompilation. Otherwise, the SQL statement
is recompiled with the new table name. This setting is the default.

On

Table Lock

DescriptionValue

The value used is the system default setting that exists at execution.<Not Set>

This value indicates whether to use table locks for the specified table or view.Enable

Table locks are not used.Off

Table locks are used.On

Timeout

DescriptionValue

The value used is the system default setting that exists at execution.<Not Set>

No timeout is specified.No Timeout

Does not wait for a table lock. If the lock cannot be acquired, SQL/MX returns an error.Will Not Wait

1 through 2147483519 in hundredths of a second.Interval

Copying a data source
If you want to create a data source that is similar to an already-configured data source, you can
use the configured data source as a template for the new data source. This procedure makes a
copy of an existing data source configuration and enables you to modify the copy as needed.
To make a copy of an existing data source:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.

MXDM displays a list of existing systems.
3. Expand the system for which you want to create a new data source.
4. Right-click Data Sources, and select Copy Data Source...

The Copy Data Source window appears.
5. Modify the required fields.

• “Using General Properties” (page 83).

NOTE: You must change the data source name. If you do not change the name, MXDM
returns an error message indicating that the data source already exists.

• “Using the DEFINEs and SETs tab” (page 85)
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• “Using the Control Query Defaults tab” (page 87)

• “Using the Control Table Statements tab” (page 87)

NOTE: If you made changes to the values in a tab, but you did not apply the changes, you
can reload the previously stored values on the server by clicking Reload.

6. Click Create.
The new data source is created.

Term
data source

Starting up a data source
When you start up the MXCS service, data sources configured with the automatic startup option
are started up.
To start up a data source:
1. Verify that the Association server for the data source is started up:

a. Check the MXCS Server Status display for the data source by performing the steps in
“Viewing MXCS Services” (page 78).

b. If the Association server is not available, start up the Association server by following the
steps in “Starting up an MXCS service” (page 79)

2. In the navigation tree pane, click the data source that you want to start up.
3. In the right pane, click the Data Source Status tab to display the list of services.
4. Select the row of the Service Name that you want to use with the data source.
5. Click Start.

The data source starts up.

Terms
association server
data source

Stopping a data source
To stop a data source:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.

MXDM displays a list of existing systems.
3. Expand the system for which you want to stop a data source.
4. Click MXCS Services.
5. In the right pane, click Data Source Status.
6. Select all of the services in which the data source is configured.
7. Click Stop...

The Stopping Data Source dialog appears.
8. In the Reason field, enter a reason for stopping the data source.
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9. Select one of the following options:

NOTE: After you click one of the stop options, you cannot cancel the operation.

• Stop on Client Disconnect

• Stop Immediately

CAUTION: Use Stop Immediately with caution. Stop Immediately stops the data source
without waiting for its associated MXCS servers to finish any current database statements
or sessions. The transaction manager rolls back all uncommitted transactions held by
these MXCS servers. All client connections are closed.

The data source stops.

Updating a data source
To update a data source:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.

MXDM displays a list of existing systems.
3. Expand the system for which you want to update a data source.
4. Right-click the data source, and select Edit...

The Configuration tab appears.
5. Modify the required fields.

• “Using General Properties” (page 83).

• “Using the DEFINEs and SETs tab” (page 85)

• “Using the Control Query Defaults tab” (page 87)

• “Using the Control Table Statements tab” (page 87)

NOTE: If you made changes to the values in a tab, but you did not apply the changes, you
can reload the previously stored values on the server by clicking Reload.

6. Click Apply.
The changes are applied.

Deleting a data source
You must stop a data source before deleting it. You cannot delete the default data source,
TDM_Default_DataSource.
To delete a data source:
1. Stop the data source by performing the steps described in “Stopping a data source” (page 90).
2. In the navigation tree pane, right-click the data source, and select Delete.
3. Click Yes to confirm the deletion.

The data source is deleted.

Term
operator permission

Starting and stopping server traces
Data from server traces is stored in the EMS log. The event ID is 21034.
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The tracing facility generates a pair of messages for each function that is traced:
• First message — Contains the input parameters to the function

• Second message — Contains the output from the function
After a trace is enabled for a data source, all servers that can write to the EMS alternate collector
begin writing the input and the output data for each function executed during the trace period.
The following data is collected for each function:
• Session ID

• Component name

• Object reference

• Sequence number

• Input values to the function or output from the function
To start tracing for data sources:
1. Under the navigation tree pane, click Connectivity.
2. In the navigation tree pane, expand the system that contains the data sources.
3. Click MXCS Services.
4. In the right pane, click Data Source Status to display the list of services.
5. In the Tracing column, select Tracing for each data source.
6. Click Apply.

Tracing starts for the data sources.

To stop tracing for a data source:
1. Under the navigation tree pane, click Connectivity.
2. In the navigation tree pane, expand the system that contains the data sources.
3. Click MXCS Services.
4. In the right pane, click Data Source Status to display the list of services.
5. In the Tracing column, clear Tracing for each data source that you want to stop tracing.
6. Click Apply.

Tracing stops for the data sources.

Related Topic
operator permission

Viewing MXCS user permissions
MXCS permissions define the type of access that a user has to manage MXCS objects on the
SQL/MX database. Only a user with OPERATOR permission can view MXCS permissions. Initially,
only the SUPER.SUPER user has OPERATOR permission.
The following are basic security rules for MXCS users:

• Only the user who installed SQL/MX (SUPER.SUPER or SUPER.SUPER alias) can manage
the user list.

• Only users with OPERATOR permission can view the user list.

• Users with USER permission cannot manage or view the user list.
Figure 37 (page 93) shows the properties in the MXCS Permissions tab. The MXCS Permission tab
indicates whether the user has OPERATOR or USER permission.
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Figure 37 MXCS Permissions tab

To view the current MXCS users:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.

MXDM displays a list of existing systems.
3. Under My Systems, select the system for which you want to view permissions.
4. In the right pane, click MXCS Permissions.

In the right pane, the permissions appear.

Related Topics
“Adding an MXCS user” (page 93)
“Editing MXCS user permissions” (page 94)
“Deleting an MXCS user” (page 94)
Term
operator permission
user permission

Adding an MXCS user
Initially, only the SUPER.SUPER user has the OPERATOR permission.
Only a SUPER.SUPER or an alias of SUPER.SUPER user can add an MXCS user.
To add an MXCS user:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.

MXDM displays a list of existing systems.
3. Under My Systems, select the system for which you want to add an MXCS user.
4. In the right pane, click MXCS Permissions.
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5. Click Add....
The Add User dialog appears.

6. Under System Users, select Operator or User.
7. From the System Users grid, select the users that you want to add to the MXCS Users grid.
8. Click Configure.

The user name is configured, and it appears in the MXCS Users pane.
9. Click Add.

The user is added.

Related Topics
“Viewing MXCS user permissions” (page 92)
“Editing MXCS user permissions” (page 94)
“Deleting an MXCS user” (page 94)
Term
operator permission

Editing MXCS user permissions
Only a SUPER.SUPER user or an alias of the SUPER.SUPER user can edit MXCS user permissions.
To edit MXCS user permission:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.

MXDM displays a list of existing systems.
3. Under My Systems, select the system on which you want to edit the MXCS user permissions.
4. In the right pane, click MXCS Permissions.
5. Select the MXCS users whose permission you want to change, and click Edit...

A confirmation dialog appears.
6. Click Yes to confirm.
7. Select the permission type, and click Ok.

The MXCS user permissions are modified.

Related Topics
“Viewing MXCS user permissions” (page 92)
“Adding an MXCS user” (page 93)
“Deleting an MXCS user” (page 94)
Term
operator permission

Deleting an MXCS user
Only a SUPER.SUPER user or an alias of the SUPER.SUPER user can delete MXCS user
permissions.
To delete an MXCS user:
1. Log on to the HP NonStop SQL/MX Database Manager.
2. Under the navigation tree pane, click Connectivity.

MXDM displays a list of existing systems.
3. Under My Systems, select the system on which you want to delete an MXCS user.
4. In the right pane, click MXCS Permissions.
5. Select the MXCS users, and click Delete.

A confirmation dialog appears.
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6. Click Yes to confirm.
The MXCS user is deleted.

Related Topics
“Viewing MXCS user permissions” (page 92)
“Adding an MXCS user” (page 93)
“Editing MXCS user permissions” (page 94)
Term
operator permission
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8 Launching the NonStop SQL/MX Remote Conversational
Interface

This chapter discusses the following topics:

• “Introduction to RMXCI” (page 96)

• “Locating the RMXCI program” (page 96)

• “Launching RMXCI” (page 96)

• “Setting Auto Logon options” (page 97)

Introduction to RMXCI
The SQL/MX database supports a client-based utility, called NonStop SQL/MX Remote
Conversational Interface (RMXCI), which enables you to enter SQL statements interactively, or from
script files in its command-line interface. You can also execute SQL statements to RMXCI from a
Perl or Python program.
For more information on RMXCI, see:

• HP NonStop SQL/MX Remote Conversational Interface (RMXCI) Guide

• Command-line help within RMXCI
The RMXCI help describes the commands supported in the current operating mode of RMXCI.
Related Topics
“Locating the RMXCI program” (page 96)
“Launching RMXCI” (page 96)
“Setting Auto Logon options” (page 97)

Locating the RMXCI program
MXDM launches RMXCI from its default installation location. If RMXCI is not found in the default
location, you can browse to determine the installation location. After MXDM launches RMXCI, the
location is cached. When required, you can change the location from where RMXCI is launched.
The MXDM application locates the RMXCI program in the RMXCI default install location. If the
RMXCI program is not found at the default installation location, you can browse for the RMXCI
installation location. After the RMXCI program is located, the location is saved. If you uninstall
RMXCI, you must use the same procedure to locate the RMXCI program again. You can change
the location of the RMXCI program at any time. To change the location, select Tools→Options...,
and modify the location.
Related Topics
“Introduction to RMXCI” (page 96)
“Launching RMXCI” (page 96)
“Setting Auto Logon options” (page 97)

Launching RMXCI
To launch RMXCI, use one of the following methods:

• From the MXDM toolbar, click SQL/MX Remote Conversational Interface ( ). For more
information on the MXDM toolbar, see “Using the MXDM toolbar” (page 29).

• Select Tools→SQL/MX Remote Conversational Interface.
The RMXCI window appears. If the Auto Logon option is enabled, you can use the user credentials
of the currently selected SQL/MX database that is connected to log on to RMXCI. The data source,
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catalog, and schema name also are considered while logging on. To set auto logon properties,
see “Setting Auto Logon options” (page 97).
You can launch more than one RMXCI window using the described methods. If you set the Auto
Logon option, the user credentials of the currently selected SQL/MX database that is connected to
log on to RMXCI are used each time.
If you select Tools→SQL/MX Remote Conversational Interface, the RMXCI window appears with
a prompt ready to execute the RMXCI commands. If RMXCI is launched and you are not logged
on to a system, RMXCI does not use the Auto logon option. Instead, RMXCI launches and prompts
you for an IP address and port number, which is the default in RMXCI.
Related Topics
“Introduction to RMXCI” (page 96)
“Locating the RMXCI program” (page 96)
“Setting Auto Logon options” (page 97)

Setting Auto Logon options
To set the RMXCI the Auto Logon option:
1. Perform one of the following:

• From the MXDM toolbar, click ( ).
The Options dialog appears.

• Select Tools→Options...
The Options dialog appears.

2. In the left pane of the Options dialog, select SQL/MX Remote Conversational Interface.
3. Enable or disable the Auto Logon option.
You can set the RMXCI prompt options. Table 27 (page 97) describes the RMXCI prompt options.

Table 27 RMXCI prompt options

DescriptionOption

Enables RMXCI auto logon.Auto Logon

Enables you to include the following options when you select Auto Logon:Prompt Options
• User

• Server

• Catalog

• Schema

• Datasource

Enables you to enter a custom prompt in the text field.Custom Prompt

NOTE: If the custom prompt contains spaces, enclose it within double quotes.

Related Topics
“Introduction to RMXCI” (page 96)
“Locating the RMXCI program” (page 96)
“Launching RMXCI” (page 96)
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A Using the SQL Whiteboard
This appendix discusses the following topics:
• “Introduction to the SQL Whiteboard” (page 98)
• “Viewing the SQL Whiteboard” (page 98)
• “SQL Whiteboard panes” (page 98)
• “Statement List pane” (page 99)
• “Statement pane” (page 100)
• “Statement Details pane” (page 102)
• “Reusing a connection ” (page 103)
• “Loading and saving SQL statements to a file” (page 103)
• “Highlighting the SQL syntax” (page 104)
• “Managing the layout of panes” (page 104)

Introduction to the SQL Whiteboard
The SQL Whiteboard enables you to enter and execute SQL statements using MXDM, and provides
execution information for each of the SQL statements.
The list of SQL statements of one MXDM session persists in other MXDM sessions. Currently, MXDM
supports only one instance of the SQL Whiteboard.
You can specify SQL statements with parameters by enclosing parameter names within a double
dollar sign ($$). When the statement is executed, the SQL Whiteboard obtains values for the
parameters in the statement. You can reuse recently used values for those parameters.
Related Topics
“Viewing the SQL Whiteboard” (page 98)
“Saving and importing system definitions” (page 45)

Viewing the SQL Whiteboard
To view the SQL Whiteboard, use one of the following methods:

• On the MXDM toolbar, click SQL Whiteboard ( ).
• Select Tools→SQL Whiteboard.
Related Topics
“SQL Whiteboard panes” (page 98)
“Using the MXDM toolbar” (page 29)

SQL Whiteboard panes
Table 28 (page 98) describes the panes in the SQL Whiteboard.

Table 28 SQL Whiteboard panes

DescriptionPane

Displays a list of the SQL statements that you added using the Statement pane.Statement List

Enables you to enter any DML or DDL statement, including SELECT, INSERT, UPDATE, DELETE,
CREATE, ALTER, GRANT, DROP, REVOKE, and so on.

Statement

Displays detailed information about the execution results.Statement Details

Figure 38 (page 99) shows the SQL Whiteboard.
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Figure 38 SQL Whiteboard

Related Topics
“Statement List pane” (page 99)
“Statement pane” (page 100)
“Statement Details pane” (page 102)

Statement List pane
The Statement List pane provides a list of SQL statements that you added in the current session or
earlier sessions of the SQL Whiteboard tool. The list of SQL statements in one MXDM session
persists in other MXDM sessions similar to how connection information and favorites persist.
From the Statement List pane, you can perform the following tasks:
• View the name and statement that was previously added in the Statement pane. Optionally,

you can explicitly add a statement to the statement list without executing it.
• Update an existing statement in the list.
• Execute a statement.
• Sort the statements based on the statement name or statement text.
Table 29 (page 99) describes the options at the top of the Statement List pane. These options
enable you to select the statements that you want to execute.

Table 29 Statement List pane options

FunctionButton

Selects all statements in the Statement List pane.All

Clears all statements in the Statement List pane.None

Removes the results only or the selected statements and the results. You cannot remove
statements alone.

Discard

NOTE: You cannot discard a statement or the results while the statement is executing. If a
currently executing statement is part of a Discard selection, it is omitted.
Use Discard when you want to free virtual memory or when MXDM indicates that system
resources are running low. Until you exit the SQL Whiteboard, the result of every executed
statement is cached. If you have already executed several large statements in the current
session, the results are cached in memory. Therefore, less memory is available for new
executions. “Page mode” (page 101) describes how the SQL Whiteboard caches and displays
large result sets.
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Statement pane
The Statement pane enables you to enter any SQL command (DDL or DML) in the text field. The
maximum number of characters you can enter in the text field is 2,147,483,647.
Table 30 (page 100) describes the fields that define a statement in the Statement pane.

Table 30 Statement pane fields

FunctionField name

Enables you to enter the name of the SQL statement. You can specify a name to identify the
statement in the statement list.

Name

Enables you to select a system from the System menu on which you want to execute the query.System

Enables you to enter the maximum rows that you want returned and displayed in the Statement
Details pane. The default is 500 rows and the maximum is 2,147,483,647.

Max Rows

Enables you to select a schema name from the Schema menu. If you do not explicitly qualify
the query by specifying a three-part ANSI name, the default schema is the currently selected
value in the menu.

Schema

Enables you to enter the number of rows to be retrieved and displayed in one page of the
statement result set. You can set a value between 1 and 100,000. Or, use the default
Rows/Page value (0), which causes MXDM to retrieve and display the entire result set.

Rows/Page

If you specify a value of 1 or more, or if you use the default setting and MXDM cannot retrieve
and cache the entire result set using available memory, MXDM automatically displays the
result set in pages. For more information on page mode, see “Page mode” (page 101).

Table 31 (page 100) describes the options at the bottom of the Statement pane that enable you to
test and modify the statement.

Table 31 Statement pane buttons

FunctionButton

Enables you to add a new SQL statement or duplicate a statement to the Statement list.Add

Enables you to update the statement. Modify the required information, and click Update.Update

Executes the statement and displays the results in the Statement Details pane.Execute

Terms
page mode

Parameter prompts
SQL statements can contain parameter names enclosed within $$ (double dollar signs). When you
execute the statement, the SQL Whiteboard prompts you for values for all parameters in that
statement. You can reuse values for those parameters.
For example, consider a table, T that contains a column T1. You can enter the following statement
in the Statement field:
Select T1 from T where T1 = $$p1$$

When you click Execute, the Parameters dialog appears.
Figure 39 (page 101) shows a sample Parameters dialog.
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Figure 39 Parameters dialog

Enter a value, for example 1. The statement is executed, and the following tabs will appear in
Statement Details dialog:
• Execution Results — Displays the output generated by the statement after the parameter is

replaced by the value you entered.
• Execution Parameters — Lists p1 parameter with value 1.
• Executed Statement — Contains Select t1 from T where t1 = 1.
You can enter another statement that uses the parameter, p1. The statement will be executed. For
example, if you enter Select * from T where T1 = $$p1$$ + $$p2$$, the same dialog
appears. However, p1 (with value one) and p2 appear.
You can enter values again.

Page mode
When you execute a statement in the SQL Whiteboard, MXDM caches the results in virtual memory.
The SQL Whiteboard displays these results, but the virtual memory allotted for the SQL Whiteboard
can exhaust in the following scenarios:
• A single query has a large result set consisting of a large number of columns or a large number

of rows, or both.
• Several queries with large result sets are executed in a single SQL Whiteboard session.
To prevent an out-of-memory condition and accommodate large result sets, the SQL Whiteboard
can run in the page mode. In the page mode, the SQL Whiteboard breaks large result sets into
pages and retrieves one page at a time instead of retrieving all the data and displaying all rows
in the grid. The page mode reduces the memory usage because only a partial result is held in
memory and displayed in the Statement Details pane.

Default page mode operation
By default, the SQL Whiteboard displays all the results of a statement. However, it automatically
runs in page mode in the following scenarios:
• Insufficient memory is available to display the result set in one page.
• You specify a value from 1 to 100,000 in the Rows/Page field of the Statement pane. In this

case, if sufficient memory is available, the SQL Whiteboard automatically uses page mode
and allocates the number of rows per page that you specified.

Page mode considerations
The following considerations apply for page mode:
• During the course of statement execution, MXDM frequently computes the available virtual

memory of the application. If the available virtual memory is less than an internal threshold,
statement execution happens in the page mode. You cannot modify this behavior. In some
cases, you must use the page mode to prevent MXDM from running out of memory and
generating an exception.

• When a statement is executed and the number of rows is less than the Rows/Page threshold,
all rows in the results are retrieved and displayed in the grid.
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• When a statement is executed and the number of rows in the result set exceeds the Rows/Page
threshold, statement execution happens in the page mode. Partial results are retrieved and
displayed.

• When statement execution happens in the page mode, the Statement Details pane displays
Next Page. The following considerations apply:

◦ Until you click Next Page, the execution is paused, and the SQL cursor remains open.
However, the Time Elapsed timer continues to run because it tracks the wait time.

◦ When you click Next Page, the next page of results is retrieved from the server. The first
page is deleted from the grid when the new page is loaded. The process repeats until
you either view all the pages or cancel the query.

◦ You cannot return to the previous page because the ODBC cursor operates in the
FORWARD mode only. To display earlier results, you must re-execute the statement.

• Regardless of whether the number of rows in the result set exceeds the Rows/Page threshold,
if the available virtual memory falls below the internal threshold, the statement execution goes
into the page mode and displays the results that have been retrieved so far. In this case, the
grid might display fewer rows than the Rows/Page threshold. This situation continues until
garbage collection begins, and the memory occupied by the pages that have been disposed
becomes available again. When the system resources are low, the Statement Details pane
displays a message that execution is in the entering page mode.

• Grid sorting works only on the currently displayed page.
• In the page mode, the following options copy data for the current page only:

Data to Clipboard◦
◦ Data to Browser

◦ Data to Spreadsheet

◦ Data to File

• To free workstation memory, you can discard the results of the selected statement(s) cached
in the Statement List pane. For more information, see “Statement List pane” (page 99).

Executing SQL queries
If you highlight text, you can execute a part of a statement.
If you highlight text in the Statement pane, and click Execute, the query formed by that text is
executed. For example, if the Statement pane contains the query, select * from t, where t1
= 1, and if you highlight the part select * from t and click Execute, select * from t is
executed.

Cancelling a query from the SQL Whiteboard
You can cancel a running query if the query is wrong, the query is inefficient, or if the query is
creating a performance issue and needs to be stopped.
After a query starts executing, the SQL Whiteboard Execute button changes to Cancel. Clicking
Cancel terminates the SQL query.

Statement Details pane
The Statement Details pane contains statistics and details generated from the selected statement
in the Statement List pane. You can use these details for reference only. The pane has no interactive
functionality. Statistics appear only for statements that are loaded from the Statement pane.
Table 32 (page 103) describes the fields that appear in the Execution Results tab when a statement
executes successfully.
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Table 32 Execution Results fields

FunctionField or button

Indicates when the statement was last evaluated.Last Evaluated

Indicates the time taken to execute the query.Query Execution Time

Displays the executed statement status. The status indicates whether the statement was
executed successfully or whether the statement was canceled.

Status

Displays the next set of execution results when the statement execution happens in the page
mode. For more information on the page mode, see “Page mode” (page 101).

Next Page

For DML statements such as INSERT, DELETE, and UPDATE, the results indicate how many rows
were affected if the execution is successful. For other SQL commands, the results appear in text
form.
For SELECT statements, you can use the Copy options to copy the results to a file, clipboard, or a
spreadsheet. The copy options are Data to Clipboard, Data to Browser, Data to Spreadsheet, and
Data to File. The data is preserved only while the SQL Whiteboard remains open. The data is
flushed when the SQL Whiteboard is closed. Also, when in the page mode, you can copy data
in the current page only.
Table 33 (page 103) describes the tabs.

Table 33 Statement Details tabs

FunctionTab

Displays the statement execution error.Execution Error

Displays values set for the current or earlier execution. The Execution Parameters tab
is displayed only if the statement has parameters.

Execution Parameters

Displays the statement that was executed with the parameters (if any), replaced with
their values.

Executed Statement

For more information on the page mode, see “Page mode” (page 101).
Related Topic
“Copying data” (page 44)
Term
page mode

Reusing a connection
The reuse connection feature is enabled by default in the SQL Whiteboard. As a result, all queries
executed for the selected system use the same connection. This system appears in the Statement
Pane, under System. To close the connection, right-click the system icon in the left pane and select
Disconnect. As a result, if the SQL Whiteboard is using the same connection, it stops. HP
recommends that you disconnect the system to release system resources.

Loading and saving SQL statements to a file
The SQL Whiteboard provides commands that enable you to import an SQL statement from a text
file to the Statement pane. You can also copy SQL statements from the Statement pane to a specified
text file.
Table 34 (page 104) describes the commands in the File menu that you can use to import and copy
SQL statements.
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Table 34 File menu options

FunctionMenu item

Loads the text of an SQL statement from an ASCII file to the Statement field.Load SQL Statement

Saves the current SQL statement text from the Statement field to an ASCII file. This
command saves only the statement text, but not the statement results. To save the results,
use the Data to Clipboard, Data To Spreadsheet, or the Data to File options.

Save SQL Statement

Related Topic
“Copying data” (page 44)

Highlighting the SQL syntax
To highlight the SQL syntax in the Statement pane, select Format→Highlight Syntax. The SQL
keywords in the SQL text are highlighted.

Managing the layout of panes
The SQL Whiteboard enables you to move and resize individual panes. After setting the layout,
select File→Lock Layout to lock the layout. Subsequently, you cannot move or resize the Statement,
Statement List, and Statement Detail panes. To unlock the layout, select File→Unlock Layout.
To reset the layout to the default configuration, select File→Reset Layout.
To ensure that the layout persists across SQL Whiteboard or MXDM invocations, select File→Save
Persistence. Subsequently, when you launch the SQL Whiteboard either in the current instance of
MXDM or in a restarted MXDM instance, the layout is restored.

NOTE: The Export Persistence option in the File menu, in the SQL Whiteboard and the Export
Persistence option in the main window have the same effect.

Related Topic
“Saving and importing system definitions” (page 45)
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Glossary
area A broad category of features that you can manage or monitor using MXDM. See “Selecting an

area” (page 30).
association server The logical component that starts up and manages MXCS SQL servers and associates a client

connection request with a specific MXCS SQL server in a data source. See also “Viewing MXCS
Services” (page 78).

connection When a user interaction requires interaction with a system, the relevant code uses the system
definition for that system to transparently establish one or more ODBC connections, as needed.

data grid A tabular presentation of system data. MXDM data grids provide special features for displaying
and manipulating data. The SQL Whiteboard Statement Details pane display information in a
data grid. Tabs in the Database area do not provide data-grid features. For more information
about data-grid features, see “Introduction to data grids” (page 40).

data source A logical name that defines the information required to access data. On the client side, the data
source defines the driver name, network address, and specific attributes, such as the catalog and
schema names. On the server side, it defines startup values, the number of servers in a pool,
DEFINEs, SQL/MX control statements, and resource management policies.

disconnect Because connections are transient, there is no concept of logging on or logging off. The MXDM
equivalent of logon is making a system usable by entering the correct settings. The MXDM
equivalent of logoff is making a system unusable by disconnecting (or invalidating any of its other
settings). Use the Disconnect function when you want the client application to continue running,
but you want to deny continued access to a system without having to remove the system definition.
See “Disconnecting from a system” (page 21).

favorite A favorite is a shortcut to an object on the navigation tree pane. Favorites appear in the My
Favorites pane. Clicking a favorite enables you to navigate quickly to any object on the tree pane
that might otherwise require scrolling through and expanding numerous parent objects. MXDM
enables you to create favorites and organize them in folders.

menu bar The menu bar is the list of commands at the top of the MXDM main window. The menu bar
commands are: File, Edit, Tools, Windows, and Help. “MXDM interface” (page 26) shows the
menu bar.

MXCS (SQL/MX
Database
Connectivity
Service)

The server component that enables connectivity from client applications to the SQL/MX database.
The SQL/MX Database Connectivity Service consists of an Association server (MXOAS or MXAS2),
a configuration server (MXOCFG), and MXCS SQL servers.

MXCS server A process that manages an ODBC connection.
MXCS Service A process that uses data sources to launch MXCS SQL servers to manage connections.
MXDM HP NonStop SQL/MX Database Manager (MXDM) is an integrated graphical user interface

(GUI) client that enables you to connect to and manage multiple NonStop SQL/MX databases.
MXOAS MXOAS is the component of the SQL/MX Database Connectivity Service (MXCS) that receives

client connection requests for database access and associates the requestor with a server to
execute the requested access. See also MXAS2.

My Systems In the navigation tree pane, a folder showing the group of SQL/MX platforms that are currently
defined in the Systems Tool. The icon for each system shows the connection status for that system.
For more information, see “Using the navigation tree” (page 33).

navigation tree
pane

The left pane of the NonStop SQL/MX Database Manager interface that displays a tree of the
database objects in a hierarchical form. “MXDM interface” (page 26) shows the navigation tree
pane.

operator
permission

An MXCS permission that allows a user to perform administrative tasks, such as managing data
source configurations, MXCS services, data sources, and servers, by making changes to status
and configuration. For more information, see “Viewing MXCS user permissions” (page 92) or
“Adding an MXCS user” (page 93).

page mode A SQL Whiteboard feature that breaks large result sets into pages and fetches one page at a
time. To prevent out-of-memory conditions, page mode limits the amount of memory used by the
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SQL Whiteboard. In page mode, only a partial result of a query is held in memory and displayed
in the Statement Details page. For more information, see “Page mode” (page 101).

persistence file A binary file that contains state and user preference information (for example, system definitions,
user-specified options, favorites, and layout information). For more information, see “Saving and
importing system definitions” (page 45).

query A request for data from the database; specifically, the execution of a SQL statement, which
requests columns and rows from one or more tables and views. In the context of the SQL/MX
optimizer, a query is a request for data access through an DML statement.

right pane The right pane of the NonStop SQL/MX Database Manager interface displays information about
the selected objects in the navigation tree pane. “MXDM interface” (page 26).

segment A subdivision of a SQL/MX cluster that consists of 16 processing nodes (CPUs). Each segment
has a name (for example, HPQ0101), and the SQL/MX cluster contains one master segment.
All other segments are considered slave segments.

SQL statement Any DML or DDL statement including, but not limited to SELECT, INSERT, UPDATE, DELETE,
CREATE, ALTER, DROP, GRANT, and REVOKE. For more information about SQL statements, see
the SQL/MX Reference Manual.

SQL Whiteboard A utility that allows you to enter and execute SQL statements from within MXDM. For more
information, see “Introduction to the SQL Whiteboard” (page 98).

system The user view of a system definition.
system definition A user-named set of all of the information required to construct an ODBC connection string: server

data source, username, password, server IP address or DNS name, port number, default schema,
and ODBC driver version. The banner displays the system definition. See “MXDM banner”
(page 27).

system monitor The system monitor is a tool within MXDM that displays status and performance data for the
SQL/MX platform. The displayed status and performance data includes seven performance metrics
and four system status icons.

Systems Tool The tool used to define, add, edit, remove, duplicate, test, and open a connection with a SQL/MX
platform. The Systems Tool is available from the Tools menu.

TDM_Default_
DataSource

One of two default data sources for the SQL/MX platform. TDM_Default_DataSource is the default
data source for database access. You cannot delete TDM_Default_DataSource, but you can
configure other data sources.

user permission MXCS permission that allows you to view data source configurations, MXCS services, MXCS
servers, and data sources. See also “Viewing MXCS user permissions” (page 92).
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Index

A
About

box, MXDM, 38
command, Help menu, 29

Add DEFINE dialog box, 85
Add SET dialog box, 86
Admin_Load_DataSource

stopping service for, 80
Alerts

data grid, customizing, 42
Application Name, MXCS Server, 77
Apply button

Configuration tab, 91
Data Source Status tab, 92

Area
connectivity, 31
database, 31
defined, 105
selecting, 30
showing and hiding, 31

Association servers
defined, 105

Available
Data Source Status, 82
Data Sources, 81

B
Banner

example, 27
location, 26

Build information
MXDM client, 38

C
Check box (green), 33
Client/server compatibility, 15
Clone in Window, 36
Close All Windows Except Main Window, 29
Closing MXDM, 25
Columns

customizing, 42
sorting and moving, 38

Comments, sending to HP, 11
Compatibility with older servers, 15
Computer Name, MXCS Server, 77
Connect / Edit System

toolbar button, 29
Connected, Data Source Status, 82
Connecting (see also Disconnecting)

defined, 105
connecting (see also disconnecting)

connecting to a system, 19
Connection

Idle Timeout, 84
information, 84

reusing, 103
timeout, 24

Contents command, Help menu, 29
Control Query Defaults tab, 87
Control Table Statements tab, 87
Copy command, 42

Edit menu, 28
toolbar button, 29

Copying data
data to clipboard, 44

copying data
data to browser, 45
data to file, 44
data to spreadsheet, 44

Count, Data Source Status, 82
CQDs, adding or modifying, 87
Create New Data Source Like, 89
Cut command

Edit menu, 28
toolbar button, 29

D
Data columns, sorting and moving, 38
Data grid

Copy command, 42
customizing, 42
defined, 105
description of, 40
row details, 41
searching, 43

Data Source
defined, 105
name, 83
performance, 83
updating, 91

Data source
copying, 89
creating, 82
deleting, 91
displaying, 81
starting up, 90
Status tab, 81
stopping, 90

Data Source Name
Data Source Status, 82
Data Sources, 81
MXCS Server, 77

Data Sources tab, 81
Data to Browser, 45
Data to Clipboard, 44
Data to File, 44
Data to Spreadsheet, 44
Data, copying, 44
Database

area, 30
DEFINEs and SETs tab, 85
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Delimited identifiers, 83
Disconnecting

toolbar button, 29
Disconnecting (see also Connecting)

defined, 105
disconnecting (see also connecting)

function, 21
Documentation

feedback on, 11
Documents, related information, 8

E
Edit DEFINE dialog box, 85
Edit menu options, 28
Edit SET dialog box, 86
Editing a system, 23
Error

messages, 38
Exit command, 28
Exiting MXDM, 25
Export Persistence command, 28

F
Favorite

considerations, 33
creating, 32
creating a folder for, 32
defined, 105
removing, 33
removing a folder for, 33
using, 32
viewing, 32

Features, new in MXDM, 7
Feedback to HP, 11
File menu options, 28

G
General properties tab, 83
Glossary, 105
Go to Next toolbar button, 29
Go to Parent toolbar button, 29
Go to Previous toolbar button, 29

H
Help

menu options, 29
toolbar button, 29

HP NonStop SQL/MX Remote Conversational Interface
(RMXCI)
auto logon options, 97
locating, 96
toolbar button, 29

I
Import Persistence

menu command, 28
toolbar button, 29

Index command, Help menu, 29
Information, new and changed, 7

L
Last State Changed, Data Source Status, 82
Last Updated Time

MXCS Server, 77
MXCS Services, 79

Load SQL Statement command, 103
Lock command, 104

M
Max Rows, SQL Whiteboard, 100
Maximum

Data Source Status, 82
Data Sources, 81

Menu bar
commands, 27
defined, 105

Monitoring area, 30
Multicolumn sorting, 39
MXCS server

defined, 105
displaying all, 76
status tab, 76
stopping, 78

MXCS service
defined, 105
displaying, 78
starting up, 79
stopping, 80

MXCS Services tab, 78
MXCS user

adding, 93
deleting, 94
editing, 94
viewing, 92

MXCS, defined, 105
MXDM

database-object browsing, 12
exiting, 25
features, 12
framework, 13
SQL Whiteboard, 12
uninstalling, 16

MXDM graphical user interface (GUI), 26
MXOAS

defined, 105
My Favorites pane, 32
My Systems, 105

navigration tree pane folder, 33
result of connecting, 19
right-clicking, 18

N
Name, SQL Whiteboard, 100
Navigation Tree Pane

overview, 33
Navigation tree pane

defined, 105
New and changed information, 7
New features, MXDM, 7
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Next Page button
description of, 103
Statement Details pane, 102

Node
MXCS Services, 79
order, 84
utilization, 84

NonStop SQL/MX Remote Conversational Interface
(RMXCI)
command, Tools menu, 29
launching, 96
learning about, 96

Number of servers, 84

O
ODBC

connection, testing, 24
Operator permission

defined, 105
Options

command, Tools menu, 29
general, 31
HP NonStop SQL/MX Remote Conversational Interface

(RMXCI), 97
show/hide area, 31
toolbar button, 29

Out-of-memory exceptions, 101

P
Page mode

defined, 105
understanding, 101

Panes
expanding and collapsing, 36
working with, 36

Parameters
SQL Whiteboard statement, 100

Password
not specified, 22

Paste command
Edit menu, 28
toolbar button, 29

Persistence file
defined, 106
saving and updating, 45

PID Client, MXCS Server, 77
Port

MXCS Server, 77
MXCS Services, 79

Process Name
MXCS Server, 77
MXCS Services, 79

Process priority, 84
Publishing history, 7

Q
Query

canceling from SQL Whiteboard, 102
defined, 106

R
Redo command

Edit menu, 28
Release compatibility, 15
Releases

supported, 15
Repair MXDM, 17
Reset Layout command, 104
Resource management

adding or modifying policies, 85
for data sources, 84

Right pane
defined, 106
using, 35

RMXCI (see also NonStop SQL/MX Remote Conversational
Interface (RMXCI), 96

Row details
getting, 41

Rows/Page
effect of, 101
field, 100
SQL Whiteboard, 100

S
Save Persistence

menu command, 28
toolbar button, 29

Save SQL Statement command, 103
Schema, default

SQL Whiteboard, 100
Search command, Help menu, 29
Segment

defined, 106
Select All command

Edit menu, 28
Server idle timeout, 83
Server PIN

MXCS Server, 77
MXCS Services, 79

Server traces, 91
Service Name

Data Source Status, 82
MXCS Server, 77
MXCS Services, 79

Service Type, MXCS Services, 79
Session statistics, 84
Session summary, 84
SET variables, 86
Shortcut

favorite, defined, 105
navigational, 32

Show/Hide Area Options, 31
Show/Hide Grid Columns, 43
Sorting data, 38
Special characters, 83
SQL statement

defined, 106
loading into SQL Whiteboard, 103
saving to ASCII file, 103
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statistics, 84
SQL Whiteboard

canceling an SQL query, 102
command, 29
defined, 106
displaying, 98
executing hightlighted test, 102
highlighting syntax, 104
loading and saving SQL statements, 103
managing layout, 104
overview, 98
parameter prompt, 100
reusing a connection, 103
statement details pane, 102
statement list, 99
statement pane, 100
toolbar button, 29

SQL/MX Database Manager
parts of, 26

SQL/MX Messages Manual, 38
Start Ahead

Data Source Status, 82
Data Sources, 81

Start Mode, 83
State

Data Source Status, 82
MXCS Server, 77
MXCS Services, 79

Statement Details pane, SQL Whiteboard, 102
Statement List pane, 99
Statement pane, 100
Statement statistics, 84
Status Bar, location of, 26
Stop Immediately, 80, 91
Stop on Client Disconnect, 91
System

add like, 23
adding, 18
connecting to, 19
defined, 106
disconnecting from, 21
editing, 23
field, Statement Pane, 100
removing, 24
testing, 24

System definition
banner display of, 27
defined, 106
saving or importing, 45

System monitor
definition, 106

Systems Tool
command, Tools menu, 29
defined, 106
options, 22
overview, 21
toolbar button, 29
using, 21

T
Tabs

cloning, 36
working with, 36

TDM_Default_DataSource
defined, 106
deleting, 91

Test command, 24
Timeout

setting the connection, 24
Toolbar

MXDM, 29
Tools menu options, 28
Tooltips, 83
Tracing

Data Source Status tab, 82

U
Undo command

Edit menu, 28
Uninstalling MXDM, 16
User Name

MXCS Server, 77
User permission

adding, 93
defined, 106
deleting, 94
editing, 94
viewing, 92

V
Version information, MXDM client, 38

W
Windows

cloning, 36
menu options, 29
working with, 36

Windows Manager
menu option, 29
toolbar button, 29
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